summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-21 05:48:04 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-21 05:48:04 +0000
commit31a963cfd0bfb4d4ad7f9cc37f28a74e9276c668 (patch)
treef558fa4504acaf14ef2f93d12ea8fa7ff8718e05 /sys-apps/file
parentget rid of duped cross compile patch (diff)
downloadhistorical-31a963cfd0bfb4d4ad7f9cc37f28a74e9276c668.tar.gz
historical-31a963cfd0bfb4d4ad7f9cc37f28a74e9276c668.tar.bz2
historical-31a963cfd0bfb4d4ad7f9cc37f28a74e9276c668.zip
grab a simple ia64 patch from redhat
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/Manifest6
-rw-r--r--sys-apps/file/file-4.13.ebuild5
-rw-r--r--sys-apps/file/files/file-4.12-cross-compile.patch30
-rw-r--r--sys-apps/file/files/file-4.13-ia64.patch16
4 files changed, 23 insertions, 34 deletions
diff --git a/sys-apps/file/Manifest b/sys-apps/file/Manifest
index b743ee787f9a..dc1e27e15cb7 100644
--- a/sys-apps/file/Manifest
+++ b/sys-apps/file/Manifest
@@ -1,10 +1,10 @@
MD5 5173afd9d8a51dd24b27504105b70f19 ChangeLog 10479
-MD5 ffbd8f0ba222731195c067f3254570f2 file-4.12.ebuild 2070
+MD5 ef98b57138e9c005ad3c7c82f382bca7 file-4.12.ebuild 2076
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 b87aec57bfd8619c711bc8218a946508 file-4.13.ebuild 2232
+MD5 9e92f5250adb77970d9e30c3ea4999f4 file-4.13.ebuild 2307
MD5 f0f2d2181cac822f0c4d4675fb1ff38c files/cracklib.magic 360
MD5 407c20e1fb3186144d6c7d2788714163 files/digest-file-4.13 61
MD5 d336b3490362624aec2e30679c44a198 files/digest-file-4.12 61
-MD5 f856a50dada76a4ca5cee58fbd04e76b files/file-4.12-cross-compile.patch 964
+MD5 7a96e5548d52493366ab39f1c6ae9237 files/file-4.13-ia64.patch 530
MD5 f856a50dada76a4ca5cee58fbd04e76b files/file-4.13-cross-compile.patch 964
MD5 66df8eecd30769daeb3f643dc6432db3 files/file-4.xx-mips-gentoo.patch 5578
diff --git a/sys-apps/file/file-4.13.ebuild b/sys-apps/file/file-4.13.ebuild
index 4ae711e0c8db..2328f7cb1caf 100644
--- a/sys-apps/file/file-4.13.ebuild
+++ b/sys-apps/file/file-4.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.13.ebuild,v 1.3 2005/05/21 04:48:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.13.ebuild,v 1.4 2005/05/21 05:48:04 vapier Exp $
inherit flag-o-matic eutils distutils libtool toolchain-funcs
@@ -23,6 +23,9 @@ src_unpack() {
# the magic and src subdir sometimes don't get along #81974
sed -i -e '/^SUBDIRS/s:magic::' Makefile.in
+ # Rename ia64 labels (from Fedora)
+ epatch "${FILESDIR}"/${P}-ia64.patch
+
# This tweaks the output format for mips binaries so things like
# libtool don't barf all over the place when trying to parse it.
epatch "${FILESDIR}"/${PN}-4.xx-mips-gentoo.patch
diff --git a/sys-apps/file/files/file-4.12-cross-compile.patch b/sys-apps/file/files/file-4.12-cross-compile.patch
deleted file mode 100644
index b2b7d3c80707..000000000000
--- a/sys-apps/file/files/file-4.12-cross-compile.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- file-4.10/magic/Makefile.in.orig 2004-07-24 14:38:55.000000000 -0600
-+++ file-4.10/magic/Makefile.in 2004-07-28 12:16:23.000000000 -0600
-@@ -490,10 +490,10 @@
- done >> $@
-
- magic.mgc: magic
-- $(top_builddir)/src/file -C -m magic
-+ /usr/bin/file -C -m magic
-
- magic.mime.mgc: magic.mime
-- $(top_builddir)/src/file -C -m $(srcdir)/magic.mime
-+ /usr/bin/file -C -m $(srcdir)/magic.mime
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
---- file-4.10/magic/Makefile.am.orig 2004-07-24 14:38:55.000000000 -0600
-+++ file-4.10/magic/Makefile.am 2004-07-28 12:18:15.000000000 -0600
-@@ -16,10 +16,10 @@
- done >> $@
-
- magic.mgc: magic
-- $(top_builddir)/src/file -C -m magic
-+ /usr/bin/file -C -m magic
-
- magic.mime.mgc: magic.mime
-- $(top_builddir)/src/file -C -m $(srcdir)/magic.mime
-+ /usr/bin/file -C -m $(srcdir)/magic.mime
-
- magic_FRAGMENTS = \
- Magdir/acorn \
diff --git a/sys-apps/file/files/file-4.13-ia64.patch b/sys-apps/file/files/file-4.13-ia64.patch
new file mode 100644
index 000000000000..afe6abaf7e86
--- /dev/null
+++ b/sys-apps/file/files/file-4.13-ia64.patch
@@ -0,0 +1,16 @@
+--- file-4.02/magic/Magdir/elf
++++ file-4.02/magic/Magdir/elf
+@@ -91,5 +91,5 @@
+ >>18 leshort 48 Hitachi H8S,
+ >>18 leshort 49 Hitachi H8/500,
+->>18 leshort 50 IA-64 (Intel 64 bit architecture)
++>>18 leshort 50 IA-64,
+ >>18 leshort 51 Stanford MIPS-X,
+ >>18 leshort 52 Motorola Coldfire,
+@@ -178,5 +178,5 @@
+ >>18 beshort 48 Hitachi H8S,
+ >>18 beshort 49 Hitachi H8/500,
+->>18 beshort 50 Intel Merced Processor,
++>>18 beshort 50 IA-64,
+ >>18 beshort 51 Stanford MIPS-X,
+ >>18 beshort 52 Motorola Coldfire,