summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-10-20 06:08:30 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-10-20 06:08:30 +0000
commit7abd772104ed8856e181883215fc5d7244715a1e (patch)
tree87e29308c7789fcda08148e5e5523482195f8589 /sys-apps/file
parentAdded gnuconfig for mips64 (diff)
downloadhistorical-7abd772104ed8856e181883215fc5d7244715a1e.tar.gz
historical-7abd772104ed8856e181883215fc5d7244715a1e.tar.bz2
historical-7abd772104ed8856e181883215fc5d7244715a1e.zip
Added gnuconfig for mips64
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/Manifest4
-rw-r--r--sys-apps/file/file-4.06.ebuild7
2 files changed, 7 insertions, 4 deletions
diff --git a/sys-apps/file/Manifest b/sys-apps/file/Manifest
index 97efed139f69..b25e59727b66 100644
--- a/sys-apps/file/Manifest
+++ b/sys-apps/file/Manifest
@@ -1,4 +1,4 @@
-MD5 06c4ec89c5fa277d7a5d2c3814204f5f ChangeLog 4002
+MD5 cdad4a73f4ad78849e69c56e41b492e9 ChangeLog 4002
MD5 9199c0027f82ae3e018e2415de888492 file-3.37.ebuild 870
MD5 11c4331cb3a68b4bd5250959127e31c0 file-3.39.ebuild 1008
MD5 864d9d78ae48573d790cc598fcc4bc40 file-3.41.ebuild 1025
@@ -6,7 +6,7 @@ MD5 20dd962c51a7b039d867a7a99645fbb5 file-4.01.ebuild 936
MD5 e593a4a7dea3146bb413dea1737d48b6 file-4.02.ebuild 1093
MD5 eaf31df54d9fcbb759afd4c5e6dcfc7e file-4.03.ebuild 1102
MD5 2cbfed7db777927d97232e204a242654 file-4.05.ebuild 1847
-MD5 a44cc5dbf234bba7af8e41dc65811fdb file-4.06.ebuild 1558
+MD5 961b3412d9d9c9fc0a15ef6c8fe97881 file-4.06.ebuild 1558
MD5 3a18c97dfcc727e6c1b701cc8c03af47 files/digest-file-3.37 267
MD5 950dd57055e8275bd852869557035f42 files/digest-file-3.39 268
MD5 eabc698678353b52ea7d9bfb724d4e1e files/digest-file-3.41 268
diff --git a/sys-apps/file/file-4.06.ebuild b/sys-apps/file/file-4.06.ebuild
index f960b4c63b84..1bd8e8605075 100644
--- a/sys-apps/file/file-4.06.ebuild
+++ b/sys-apps/file/file-4.06.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.06.ebuild,v 1.4 2003/10/18 10:04:04 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.06.ebuild,v 1.5 2003/10/20 06:08:26 kumba Exp $
-inherit flag-o-matic
+inherit flag-o-matic gnuconfig
DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
@@ -30,6 +30,9 @@ src_unpack() {
src_compile() {
+ # If running mips64, we need updated configure data
+ use mips && gnuconfig_update
+
# file command segfaults on hppa - reported by gustavo@zacarias.com.ar
[ ${ARCH} = "hppa" ] && filter-flags "-mschedule=8000"