summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-04-09 16:09:35 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-04-09 16:09:35 +0000
commitcbc9344fed9ed1395433ef177c7fd5d0c07ec71e (patch)
treeed093039be184bd58e325bbb73953b80ec853547 /sys-apps/grep/grep-2.5.4-r1.ebuild
parentBump. No longer include .la and .a files. Revision bump for 7.8 with the same... (diff)
downloadhistorical-cbc9344fed9ed1395433ef177c7fd5d0c07ec71e.tar.gz
historical-cbc9344fed9ed1395433ef177c7fd5d0c07ec71e.tar.bz2
historical-cbc9344fed9ed1395433ef177c7fd5d0c07ec71e.zip
Revision bump for new libpcre. We can now use libpcre.so since it's in /lib - bug 1638 and bug 53627. Change DEPENDS of previous versions to reflect this, since new libpcre no longer includes .a archives.
Package-Manager: portage-2.2_rc28/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/grep/grep-2.5.4-r1.ebuild')
-rw-r--r--sys-apps/grep/grep-2.5.4-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/grep/grep-2.5.4-r1.ebuild b/sys-apps/grep/grep-2.5.4-r1.ebuild
new file mode 100644
index 000000000000..973810950222
--- /dev/null
+++ b/sys-apps/grep/grep-2.5.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.4-r1.ebuild,v 1.1 2009/04/09 16:09:35 loki_val Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="GNU regular expression matcher"
+HOMEPAGE="http://www.gnu.org/software/grep/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~amd64-fbsd ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls pcre"
+
+RDEPEND="nls? ( virtual/libintl )
+ pcre? ( >=dev-libs/libpcre-7.8-r1 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.5.3-po-builddir-fix.patch
+ epatch "${FILESDIR}"/${PN}-2.5.3-nls.patch
+}
+
+src_configure() {
+ econf \
+ --bindir=/bin \
+ $(use_enable nls) \
+ $(use_enable pcre perl-regexp) \
+ $(use elibc_FreeBSD || echo --without-included-regex) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}