summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2002-04-27 10:41:11 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2002-04-27 10:41:11 +0000
commit763569e380eaebb6c1542f7f06745077fc65a64b (patch)
treec3e2d79cc1778061fd10bbd736260e57ce3d580e /sys-apps/hfsutils
parentcleanup (diff)
downloadhistorical-763569e380eaebb6c1542f7f06745077fc65a64b.tar.gz
historical-763569e380eaebb6c1542f7f06745077fc65a64b.tar.bz2
historical-763569e380eaebb6c1542f7f06745077fc65a64b.zip
PPC sys-apps merge
Diffstat (limited to 'sys-apps/hfsutils')
-rw-r--r--sys-apps/hfsutils/Changelog9
-rw-r--r--sys-apps/hfsutils/files/digest-hfsutils-3.2.61
-rw-r--r--sys-apps/hfsutils/hfsutils-3.2.6.ebuild54
3 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/hfsutils/Changelog b/sys-apps/hfsutils/Changelog
new file mode 100644
index 000000000000..2951946bd466
--- /dev/null
+++ b/sys-apps/hfsutils/Changelog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-apps/hfsutils
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Id: Changelog,v 1.1 2002/04/27 10:28:33 pvdabeel Exp $
+
+*hfsutils-3.2.6 (Sun Mar 17 23:27:28 CST 2002)
+
+Sun Mar 17 23:29:06 CST 2002; Kain <kain@kain.org> all:
+
+ This is an initial .ebuild for hfsutils 3.2.6 for ppc machines.
diff --git a/sys-apps/hfsutils/files/digest-hfsutils-3.2.6 b/sys-apps/hfsutils/files/digest-hfsutils-3.2.6
new file mode 100644
index 000000000000..7cdf8f29675b
--- /dev/null
+++ b/sys-apps/hfsutils/files/digest-hfsutils-3.2.6
@@ -0,0 +1 @@
+MD5 fa572afd6da969e25c1455f728750ec4 hfsutils-3.2.6.tar.gz 207697
diff --git a/sys-apps/hfsutils/hfsutils-3.2.6.ebuild b/sys-apps/hfsutils/hfsutils-3.2.6.ebuild
new file mode 100644
index 000000000000..b626795229ac
--- /dev/null
+++ b/sys-apps/hfsutils/hfsutils-3.2.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Kain X <kain@kain.org>
+# $Id: hfsutils-3.2.6.ebuild,v 1.1 2002/04/27 10:28:33 pvdabeel Exp $
+
+# Source directory; the dir where the sources can be found
+# (automatically unpacked) inside ${WORKDIR}. Usually you can just
+# leave this as-is.
+S=${WORKDIR}/${P}
+
+# Short one-line description of this package.
+DESCRIPTION="HFS FS Access utils"
+
+# Point to any required sources; these will be automatically
+# downloaded by Portage.
+SRC_URI="ftp://ftp.mars.org/pub/hfs/${P}.tar.gz"
+
+# Homepage, not used by Portage directly but handy for developer reference
+HOMEPAGE="http://www.mars.org/home/rob/proj/hfs/"
+
+# Build-time dependencies, such as
+# ssl? ( >=openssl-0.9.6b )
+# >=perl-5.6.1-r1
+# It is advisable to use the >= syntax show above, to reflect what you
+# had installed on your system when you tested the package. Then
+# other users hopefully won't be caught without the right version of
+# a dependency.
+DEPEND=""
+
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+#RDEPEND=""
+
+MAKEOPTS='PREFIX=/usr MANDIR=/usr/share/man'
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ dodir /usr/bin
+ dodir /usr/lib
+ dodir /usr/share/man
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+}