summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-24 04:41:47 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-24 04:41:47 +0000
commitd9a92d4a20c74c411c3ecb465dd31c2874fc45b6 (patch)
tree905064a2107147b28e67d00d13b8f1d8d59f70c5 /sys-apps/hotplug-base/hotplug-base-20040401.ebuild
parentfixing Manifest (diff)
downloadhistorical-d9a92d4a20c74c411c3ecb465dd31c2874fc45b6.tar.gz
historical-d9a92d4a20c74c411c3ecb465dd31c2874fc45b6.tar.bz2
historical-d9a92d4a20c74c411c3ecb465dd31c2874fc45b6.zip
hppa stable
Diffstat (limited to 'sys-apps/hotplug-base/hotplug-base-20040401.ebuild')
-rw-r--r--sys-apps/hotplug-base/hotplug-base-20040401.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/sys-apps/hotplug-base/hotplug-base-20040401.ebuild b/sys-apps/hotplug-base/hotplug-base-20040401.ebuild
index d53fcf71fcbd..e8723f307d24 100644
--- a/sys-apps/hotplug-base/hotplug-base-20040401.ebuild
+++ b/sys-apps/hotplug-base/hotplug-base-20040401.ebuild
@@ -1,27 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug-base/hotplug-base-20040401.ebuild,v 1.3 2004/04/15 17:18:20 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug-base/hotplug-base-20040401.ebuild,v 1.4 2004/04/24 04:41:47 vapier Exp $
inherit eutils
# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
MY_P=hotplug-${PV:0:4}_${PV:4:2}_${PV:6:2}
-S=${WORKDIR}/${MY_P}
DESCRIPTION="Base Hotplug framework"
HOMEPAGE="http://linux-hotplug.sourceforge.net"
SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc sparc ~alpha ~hppa ~amd64 ~ia64 ~mips"
+SLOT="0"
+KEYWORDS="x86 ppc sparc ~mips ~alpha hppa ~amd64 ~ia64"
+IUSE=""
-src_unpack() {
- unpack ${A}
-}
+S=${WORKDIR}/${MY_P}
src_install() {
into /
- dosbin sbin/hotplug
- keepdir /etc/hotplug.d/
+ dosbin sbin/hotplug || die
+ keepdir /etc/hotplug.d
}
-