summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-06-11 13:18:52 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-06-11 13:18:52 +0000
commit31318e1d686c33aa3718f1d7c9445fe44c778ffd (patch)
tree7e3d467cc493020eaa5acf7d629f77d1f967ee38 /sys-apps/iproute2/iproute2-9999.ebuild
parentadd ~arm, bug #359137 (diff)
downloadhistorical-31318e1d686c33aa3718f1d7c9445fe44c778ffd.tar.gz
historical-31318e1d686c33aa3718f1d7c9445fe44c778ffd.tar.bz2
historical-31318e1d686c33aa3718f1d7c9445fe44c778ffd.zip
Cleanup live version to use git-2 and base eclasses, EAPI=4, remove wrong prepalldocs call. Version bump to 2.6.38 (copy from live) which works with latest iptables. Punt all overshadowed versions keeping 2 in testing and 2 in stable. This also fixes bug #370793.
Package-Manager: portage-2.2.0_alpha39/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/iproute2/iproute2-9999.ebuild')
-rw-r--r--sys-apps/iproute2/iproute2-9999.ebuild66
1 files changed, 30 insertions, 36 deletions
diff --git a/sys-apps/iproute2/iproute2-9999.ebuild b/sys-apps/iproute2/iproute2-9999.ebuild
index 216d08d0615b..855c66792a26 100644
--- a/sys-apps/iproute2/iproute2-9999.ebuild
+++ b/sys-apps/iproute2/iproute2-9999.ebuild
@@ -1,44 +1,48 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-9999.ebuild,v 1.14 2011/04/14 09:46:42 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-9999.ebuild,v 1.15 2011/06/11 13:18:51 scarabeus Exp $
-EAPI="2"
+EAPI=4
-inherit eutils toolchain-funcs flag-o-matic
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git"
+[[ ${PV} == "9999" ]] && SCM_ECLASS="git-2"
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git"
- inherit git
- SRC_URI=""
- #KEYWORDS=""
+if [[ ${PV} == *.*.*.* ]] ; then
+ MY_PV=${PV%.*}-${PV##*.}
else
- if [[ ${PV} == *.*.*.* ]] ; then
- MY_PV=${PV%.*}-${PV##*.}
- else
- MY_PV=${PV}
- fi
- MY_P="${PN}-${MY_PV}"
- SRC_URI="http://developer.osdl.org/dev/iproute2/download/${MY_P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
- S=${WORKDIR}/${MY_P}
+ MY_PV=${PV}
fi
+MY_P="${PN}-${MY_PV}"
+
+inherit eutils toolchain-funcs flag-o-matic base ${SCM_ECLASS}
+unset SCM_ECLASS
DESCRIPTION="kernel routing and traffic control utilities"
HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2"
+[[ ${PV} == "9999" ]] || SRC_URI="http://developer.osdl.org/dev/iproute2/download/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
+[[ ${PV} == "9999" ]] || KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="atm berkdb minimal"
RDEPEND="!net-misc/arpd
!minimal? ( berkdb? ( sys-libs/db ) )
atm? ( net-dialup/linux-atm )"
DEPEND="${RDEPEND}
- elibc_glibc? ( >=sys-libs/glibc-2.7 )
sys-devel/flex
- >=sys-kernel/linux-headers-2.6.27"
+ >=sys-kernel/linux-headers-2.6.27
+ elibc_glibc? ( >=sys-libs/glibc-2.7 )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.6.29.1-hfsc.patch" #291907
+)
src_prepare() {
+ base_src_prepare
+
sed -i \
-e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
-e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
@@ -47,10 +51,6 @@ src_prepare() {
# build against system headers
rm -r include/netinet #include/linux include/ip{,6}tables{,_common}.h include/libiptc
- epatch "${FILESDIR}"/${PN}-2.6.29.1-hfsc.patch #291907
-
- epatch_user
-
# don't build arpd if USE=-berkdb #81660
use berkdb || sed -i '/^TARGETS=/s: arpd : :' misc/Makefile
@@ -58,10 +58,7 @@ src_prepare() {
}
src_configure() {
- echo -n 'TC_CONFIG_ATM:=' > Config
- use atm \
- && echo 'y' >> Config \
- || echo 'n' >> Config
+ echo "TC_CONFIG_ATM:=$(use atm && echo "y" || echo "n")" > Config
# Use correct iptables dir, #144265 #293709
append-cppflags -DIPT_LIB_DIR=\\\"`$(tc-getPKG_CONFIG) xtables --variable=xtlibdir`\\\"
@@ -70,14 +67,13 @@ src_configure() {
src_compile() {
emake \
CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- || die
+ AR="$(tc-getAR)"
}
src_install() {
if use minimal ; then
into /
- dosbin tc/tc || die "minimal"
+ dosbin tc/tc
return 0
fi
@@ -86,18 +82,16 @@ src_install() {
SBINDIR=/sbin \
DOCDIR=/usr/share/doc/${PF} \
MANDIR=/usr/share/man \
- install \
- || die
- prepalldocs
+ install
- dolib.a lib/libnetlink.a || die
+ dolib.a lib/libnetlink.a
insinto /usr/include
- doins include/libnetlink.h || die
+ doins include/libnetlink.h
if use berkdb ; then
dodir /var/lib/arpd
# bug 47482, arpd doesn't need to be in /sbin
dodir /usr/sbin
- mv "${D}"/sbin/arpd "${D}"/usr/sbin/
+ mv "${ED}"/sbin/arpd "${ED}"/usr/sbin/
fi
}