summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-03-24 18:18:29 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-03-24 18:18:29 +0000
commit3f9d4ad3e4d8cb77809bb22916f714cd941d20fb (patch)
treedd005e91569518b33919a41160fda0b73464741d /sys-apps/lsof
parentIncluding patch submitted in bug #45612 to fix alsa+dmix+artsd. (diff)
downloadhistorical-3f9d4ad3e4d8cb77809bb22916f714cd941d20fb.tar.gz
historical-3f9d4ad3e4d8cb77809bb22916f714cd941d20fb.tar.bz2
historical-3f9d4ad3e4d8cb77809bb22916f714cd941d20fb.zip
Version bumped. Closes 45605
Diffstat (limited to 'sys-apps/lsof')
-rw-r--r--sys-apps/lsof/ChangeLog9
-rw-r--r--sys-apps/lsof/Manifest8
-rw-r--r--sys-apps/lsof/files/digest-lsof-4.711
-rw-r--r--sys-apps/lsof/lsof-4.71.ebuild68
4 files changed, 81 insertions, 5 deletions
diff --git a/sys-apps/lsof/ChangeLog b/sys-apps/lsof/ChangeLog
index f4dec16a490e..971c32ae4146 100644
--- a/sys-apps/lsof/ChangeLog
+++ b/sys-apps/lsof/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/lsof
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/ChangeLog,v 1.19 2003/10/26 23:02:22 aliz Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/ChangeLog,v 1.20 2004/03/24 18:18:29 mholzer Exp $
+
+*lsof-4.71 (24 Mar 2004)
+
+ 24 Mar 2004; Martin Holzer <mholzer@gentoo.org> lsof-4.71.ebuild:
+ Version bumped. Closes 45605
*lsof-4.69 (26 Oct 2003)
diff --git a/sys-apps/lsof/Manifest b/sys-apps/lsof/Manifest
index 20dd4ffe7fd2..0a42f97c6234 100644
--- a/sys-apps/lsof/Manifest
+++ b/sys-apps/lsof/Manifest
@@ -1,9 +1,11 @@
-MD5 9c0a70fe01ae31ec4e004b8bc746832b lsof-4.67.ebuild 1549
-MD5 440ca08384d8bdf3da3a8a8ab5b318a1 lsof-4.69.ebuild 1816
+MD5 6df8d14f4056578bf16addfed1657a3f ChangeLog 2678
MD5 3fffec62a3278a98c22bc6c92314d2d0 lsof-4.64.ebuild 1543
+MD5 9c0a70fe01ae31ec4e004b8bc746832b lsof-4.67.ebuild 1549
MD5 05cb6d494ef1bb2592c84c4c330fd6d6 lsof-4.68.ebuild 1808
-MD5 df8183c3d7c2af91c553739f089c7c13 ChangeLog 2549
+MD5 440ca08384d8bdf3da3a8a8ab5b318a1 lsof-4.69.ebuild 1816
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 20b248bf9b16dbf07adbc99d5ed43177 lsof-4.71.ebuild 1815
+MD5 17950eec4cb0ad6f3a3b6a521239dcbe files/digest-lsof-4.71 62
MD5 8d9d90e05e24a5ffaf927bb83670715a files/digest-lsof-4.64 61
MD5 4da5c4c30e43d53ea46517baa6125d1a files/digest-lsof-4.67 61
MD5 ce8b6000c8273dd5481bc4f4fcdd9ec2 files/digest-lsof-4.68 61
diff --git a/sys-apps/lsof/files/digest-lsof-4.71 b/sys-apps/lsof/files/digest-lsof-4.71
new file mode 100644
index 000000000000..dba179a8b9dc
--- /dev/null
+++ b/sys-apps/lsof/files/digest-lsof-4.71
@@ -0,0 +1 @@
+MD5 a4e102726b2ffe0416d23a1c4f513aaa lsof_4.71.tar.gz 1002139
diff --git a/sys-apps/lsof/lsof-4.71.ebuild b/sys-apps/lsof/lsof-4.71.ebuild
new file mode 100644
index 000000000000..edab89bc3a24
--- /dev/null
+++ b/sys-apps/lsof/lsof-4.71.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lsof/lsof-4.71.ebuild,v 1.1 2004/03/24 18:18:29 mholzer Exp $
+
+inherit flag-o-matic
+
+MY_P=${P/-/_}
+S=${WORKDIR}/${MY_P}/${MY_P}_src
+DESCRIPTION="Lists open files for running Unix processes"
+HOMEPAGE="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/README"
+SRC_URI="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.gz
+ ftp://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/lsof/${MY_P}.tar.gz"
+
+DEPEND="virtual/glibc"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~mips ~ia64"
+IUSE="static"
+
+#This pkg appears to be highly kernel-dependent.
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/${MY_P}
+ tar xf ${MY_P}_src.tar || die
+}
+
+src_compile() {
+
+ # #26576 lsof 4.68 compile with -fstack-protector fails on Alpha
+ # -taviso (15 Aug 03)
+ use alpha && filter-flags -fstack-protector
+
+ use static && LDFLAGS="${LDFLAGS} -static"
+
+ #interactive script: Enable HASSECURITY, WARNINGSTATE, and HASKERNIDCK
+ #is there a way to avoid the "echo to a file + file read"?
+ #Just piping in the results didn't seem to work.
+ echo -e "y\ny\ny\nn\ny\ny\n" > ${T}/junk
+ ./Configure linux < ${T}/junk
+
+ #simple Makefile hack to insert CFLAGS
+ cp Makefile Makefile.orig
+ sed \
+ -e "s/-DLINUXV/${CFLAGS} -DLINUXV/" \
+ -e "/^CFGL=/ s/\$/ ${LDFLAGS}/" \
+ Makefile.orig > Makefile
+
+ make all || die
+}
+
+src_install() {
+ #/usr/sbin is a good location -- drobbins
+ dosbin lsof
+ # .a libs not needed during boot so they go in /usr/lib -- drobbins
+ dolib lib/liblsof.a
+ insinto /usr/share/lsof/scripts
+ doins scripts/*
+ doman lsof.8
+ local x
+ for x in 00*
+ do
+ newdoc ${x} ${x/00/}
+ done
+ cd ${D}/usr/share/doc/${PF}
+ mv .README.FIRST.gz README.FIRST.gz
+}