summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-08-09 21:38:41 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-08-09 21:38:41 +0000
commit27fc82cb3734309c8090514746eaeb57f3035866 (patch)
tree5986d3c4f4515cde9a306bcc1556cece94137297 /sys-apps/sg3_utils
parentNo longer installs /etc/mime.types - RDEPENDs on app-misc/mime-types instead (diff)
downloadhistorical-27fc82cb3734309c8090514746eaeb57f3035866.tar.gz
historical-27fc82cb3734309c8090514746eaeb57f3035866.tar.bz2
historical-27fc82cb3734309c8090514746eaeb57f3035866.zip
Added a patch to solve PIC issues; bug #59832.
Diffstat (limited to 'sys-apps/sg3_utils')
-rw-r--r--sys-apps/sg3_utils/ChangeLog8
-rw-r--r--sys-apps/sg3_utils/Manifest5
-rw-r--r--sys-apps/sg3_utils/files/sg3_utils-llseek.patch69
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.06.ebuild13
4 files changed, 90 insertions, 5 deletions
diff --git a/sys-apps/sg3_utils/ChangeLog b/sys-apps/sg3_utils/ChangeLog
index 5aa5c14bc52d..a3be472f5919 100644
--- a/sys-apps/sg3_utils/ChangeLog
+++ b/sys-apps/sg3_utils/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for sys-apps/sg3_utils
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.4 2004/08/09 15:38:41 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.5 2004/08/09 21:38:41 plasmaroo Exp $
+
+ 09 Aug 2004; <plasmaroo@gentoo.org> sg3_utils-1.06.ebuild,
+ +files/sg3_utils-llseek.patch:
+ Added a patch to solve PIC issues; bug #59832.
09 Aug 2004; Travis Tilley <lv@gentoo.org> sg3_utils-1.06.ebuild:
- added ~amd64 keyword
+ Added ~amd64 keyword.
18 Jun 2004; Jason Wever <weeve@gentoo.org> sg3_utils-1.06.ebuild:
Added ~sparc keyword.
diff --git a/sys-apps/sg3_utils/Manifest b/sys-apps/sg3_utils/Manifest
index 9274cf118f58..6cce4ae4247b 100644
--- a/sys-apps/sg3_utils/Manifest
+++ b/sys-apps/sg3_utils/Manifest
@@ -1,4 +1,5 @@
-MD5 d4fec345ada0acef0e303d53c319e69b sg3_utils-1.06.ebuild 586
-MD5 fdfdec052633a1f66ebd13c23bb7053a ChangeLog 521
+MD5 e08a1cbf94c920c5ab2e7352414f068b ChangeLog 673
+MD5 056ba9d88997262bc82bbcba5e3c5f25 sg3_utils-1.06.ebuild 725
MD5 37443e54165d5bcdaa8550d52edafa98 metadata.xml 228
+MD5 415ccd09bf2a67e4ccc39d50059b8c14 files/sg3_utils-llseek.patch 1948
MD5 18e1643c00f4fa0f0faf858f1677631a files/digest-sg3_utils-1.06 63
diff --git a/sys-apps/sg3_utils/files/sg3_utils-llseek.patch b/sys-apps/sg3_utils/files/sg3_utils-llseek.patch
new file mode 100644
index 000000000000..281ed60abf1d
--- /dev/null
+++ b/sys-apps/sg3_utils/files/sg3_utils-llseek.patch
@@ -0,0 +1,69 @@
+diff -Naur sg3_utils-1.06-orig/llseek.c sg3_utils-1.06/llseek.c
+--- sg3_utils-1.06-orig/llseek.c 2003-10-19 05:36:40.000000000 -0400
++++ sg3_utils-1.06/llseek.c 2004-08-09 03:46:19.973864969 -0400
+@@ -14,7 +14,7 @@
+ #include <errno.h>
+ #include <unistd.h>
+
+-#if defined(__GNUC__) || defined(HAS_LONG_LONG)
++#if defined(__GNUC__)
+ typedef long long llse_loff_t;
+ #else
+ typedef long llse_loff_t;
+@@ -24,54 +24,16 @@
+
+ #ifdef __linux__
+
+-#ifdef HAVE_LLSEEK
+-#include <syscall.h>
+-
+-#else /* HAVE_LLSEEK */
+-
+ #if defined(__alpha__) || defined(__ia64__) || defined(__s390x__)
+
+ #define my_llseek lseek
+
+ #else
+-#include <linux/unistd.h> /* for __NR__llseek */
+-
+-static int _llseek (unsigned int, unsigned long,
+- unsigned long, llse_loff_t *, unsigned int);
+-
+-#ifdef __NR__llseek
+-
+-static _syscall5(int,_llseek,unsigned int,fd,unsigned long,offset_high,
+- unsigned long, offset_low,llse_loff_t *,result,
+- unsigned int, origin)
+-
+-#else
+-
+-/* no __NR__llseek on compilation machine - might give it explicitly */
+-static int _llseek (unsigned int fd, unsigned long oh,
+- unsigned long ol, llse_loff_t *result,
+- unsigned int origin) {
+- errno = ENOSYS;
+- return -1;
+-}
+-
+-#endif
+
+-static llse_loff_t my_llseek (unsigned int fd, llse_loff_t offset,
+- unsigned int origin)
+-{
+- llse_loff_t result;
+- int retval;
+-
+- retval = _llseek (fd, ((unsigned long long) offset) >> 32,
+- ((unsigned long long) offset) & 0xffffffff,
+- &result, origin);
+- return (retval == -1 ? (llse_loff_t) retval : result);
+-}
++#define my_llseek lseek64
+
+-#endif /* __alpha__ */
++#endif /* alpha, ia64, s390x */
+
+-#endif /* HAVE_LLSEEK */
+
+ llse_loff_t llse_llseek (unsigned int fd, llse_loff_t offset,
+ unsigned int origin)
diff --git a/sys-apps/sg3_utils/sg3_utils-1.06.ebuild b/sys-apps/sg3_utils/sg3_utils-1.06.ebuild
index fdd1b11f7808..c502a1f519e7 100644
--- a/sys-apps/sg3_utils/sg3_utils-1.06.ebuild
+++ b/sys-apps/sg3_utils/sg3_utils-1.06.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/sg3_utils-1.06.ebuild,v 1.4 2004/08/09 15:38:41 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/sg3_utils-1.06.ebuild,v 1.5 2004/08/09 21:38:41 plasmaroo Exp $
+
+inherit eutils
DESCRIPTION="Sg3_utils provide a collection of programs that use the sg SCSI interface"
HOMEPAGE="http://www.torque.net/sg/"
@@ -14,6 +16,15 @@ IUSE=""
DEPEND=""
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-llseek.patch
+
+ sed -i "s:-O2:$CFLAGS:g" Makefile
+}
+
src_compile() {
emake || die
}