summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Barisani <lcars@gentoo.org>2006-04-28 13:56:30 +0000
committerAndrea Barisani <lcars@gentoo.org>2006-04-28 13:56:30 +0000
commit3c0e17622d667b4a1753907cf2d57724a433a0fb (patch)
tree2c264fdce9e8b45fb1a8d4489a26443016eda39f /sys-apps/systrace/systrace-1.6d-r1.ebuild
parentupdate (diff)
downloadhistorical-3c0e17622d667b4a1753907cf2d57724a433a0fb.tar.gz
historical-3c0e17622d667b4a1753907cf2d57724a433a0fb.tar.bz2
historical-3c0e17622d667b4a1753907cf2d57724a433a0fb.zip
new systrace revision
Package-Manager: portage-2.0.54
Diffstat (limited to 'sys-apps/systrace/systrace-1.6d-r1.ebuild')
-rw-r--r--sys-apps/systrace/systrace-1.6d-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/systrace/systrace-1.6d-r1.ebuild b/sys-apps/systrace/systrace-1.6d-r1.ebuild
new file mode 100644
index 000000000000..d0a7411e0a2e
--- /dev/null
+++ b/sys-apps/systrace/systrace-1.6d-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systrace/systrace-1.6d-r1.ebuild,v 1.1 2006/04/28 13:56:30 lcars Exp $
+
+inherit eutils
+
+DESCRIPTION="Interactive Policy Generation for System Calls"
+HOMEPAGE="http://www.systrace.org/"
+SRC_URI="http://www.citi.umich.edu/u/provos/systrace/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND="dev-libs/libevent"
+DEPEND="$RDEPEND
+ >=sys-devel/autoconf-2.58"
+
+SYSTR_HEADER="${ROOT}usr/src/linux/include/linux/systrace.h"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ if [ -f /usr/include/linux/systrace.h ] ; then
+ SYSTR_HEADER="/usr/include/linux/systrace.h"
+ fi
+
+ if ! [ -f ${SYSTR_HEADER} ] ; then
+ einfo
+ einfo "${SYSTR_HEADER} not found. Using ptrace-based backend."
+ einfo
+ epatch "${FILESDIR}"/systrace-regress.patch
+ else
+ einfo
+ einfo "${SYSTR_HEADER} found. Assuming /dev/systrace."
+ einfo
+ sed -i -e "s/all:.\+/all:/" ./regress/Makefile.am
+ sed -i -e "s:linux\/systrace.h:${SYSTR_HEADER}:" ./configure
+ sed -i -e "s:<linux\/systrace.h>:\"${SYSTR_HEADER}\":" ./linux-syscalls.c
+ fi
+
+ export WANT_AUTOCONF=2.5
+}
+
+src_install() {
+ dobin systrace || die
+ doman systrace.1
+}