summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Jones <carpaski@gentoo.org>2002-11-30 02:42:18 +0000
committerNicholas Jones <carpaski@gentoo.org>2002-11-30 02:42:18 +0000
commit60eae804eca5872336644afd79c62a39ce30a99a (patch)
tree8313d818f61b1642ab3c3eea4a9f49de7ce08c99 /sys-apps/util-linux
parentChanged einstall||die to einstall (diff)
downloadhistorical-60eae804eca5872336644afd79c62a39ce30a99a.tar.gz
historical-60eae804eca5872336644afd79c62a39ce30a99a.tar.bz2
historical-60eae804eca5872336644afd79c62a39ce30a99a.zip
2.11y release... Mostly cleanups.
Redid the 2.11r crypt patch to work on 2.11y.
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog9
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.11y2
-rw-r--r--sys-apps/util-linux/util-linux-2.11y.ebuild79
3 files changed, 89 insertions, 1 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 6756b2a9d7d4..275a3a07dc59 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/util-linux
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.14 2002/10/27 07:43:12 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.15 2002/11/30 02:42:18 carpaski Exp $
+
+*util-linux-2.11y (27 Oct 2002)
+
+ 29 Nov 2002; Nicholas Jones <carpaski@gentoo.org> :
+ Latest release. Patched 2.11r crypto patch for this version.
+ On mirrors as util-linux-2.11y-crypt-gentoo.patch.gz
+ Updates are mostly cleanups.
*util-linux-2.11w (27 Oct 2002)
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.11y b/sys-apps/util-linux/files/digest-util-linux-2.11y
new file mode 100644
index 000000000000..6031b7284646
--- /dev/null
+++ b/sys-apps/util-linux/files/digest-util-linux-2.11y
@@ -0,0 +1,2 @@
+MD5 088a2a289119a17229c20553aa8c24f5 util-linux-2.11y.tar.gz 1820145
+MD5 45133b34f10632f3ffc012401e2a4b19 util-linux-2.11y-crypt-gentoo.patch.gz 18843
diff --git a/sys-apps/util-linux/util-linux-2.11y.ebuild b/sys-apps/util-linux/util-linux-2.11y.ebuild
new file mode 100644
index 000000000000..d223813b0e4f
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-2.11y.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11y.ebuild,v 1.1 2002/11/30 02:42:18 carpaski Exp $
+
+IUSE="crypt nls"
+
+CRYPT_PATCH_P=${P}-crypt-gentoo
+S=${WORKDIR}/${P}
+DESCRIPTION="Various useful Linux utilities"
+SRC_URI="http://www.kernel.org/pub/linux/utils/${PN}/${P}.tar.gz
+ crypt? ( http://gentoo.twobit.net/misc/${CRYPT_PATCH_P}.patch.gz )"
+# Patched for 2.11y -- NJ <carpaski@gentoo.org)
+# crypt? ( http://www.kernel.org/pub/linux/kernel/people/hvr/util-linux-patch-int/${CRYPT_PATCH_P}.patch.gz )"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r2
+ sys-apps/pam-login"
+
+RDEPEND="$DEPEND sys-devel/perl
+ nls? ( sys-devel/gettext )"
+
+SLOT="0"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+
+ if [ ! -z "`use crypt`" ]
+ then
+ gunzip -c ${DISTDIR}/${CRYPT_PATCH_P}.patch.gz | patch -p1 || die "crypto patch"
+ fi
+
+ cp MCONFIG MCONFIG.orig
+ sed -e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
+ -e "s:CPU=.*:CPU=${CHOST%%-*}:" \
+ -e "s:HAVE_PAM=no:HAVE_PAM=yes:" \
+ -e "s:HAVE_SLN=no:HAVE_SLN=yes:" \
+ -e "s:HAVE_TSORT=no:HAVE_TSORT=yes:" \
+ -e "s:usr/man:usr/share/man:" \
+ -e "s:usr/info:usr/share/info:" \
+ MCONFIG.orig > MCONFIG
+}
+
+src_compile() {
+
+ ./configure || die "config"
+
+ if [ -z "`use nls`" ]
+ then
+ cp defines.h defines.h.orig
+ grep -v "ENABLE_NLS" \
+ defines.h.orig > defines.h
+ cp defines.h defines.h.orig
+ grep -v "HAVE_libintl_h" \
+ defines.h.orig > defines.h
+
+ cp Makefile Makefile.orig
+ sed -e "s:SUBDIRS=po \\\:SUBDIRS= \\\:g" \
+ Makefile.orig > Makefile
+ fi
+
+ emake LDFLAGS="" || die
+ cd sys-utils; makeinfo *.texi || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc HISTORY MAINTAINER README VERSION
+ docinto licenses
+ dodoc licenses/* HISTORY
+ docinto examples
+ dodoc example.files/*
+}
+