summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-05-23 21:12:43 +0000
committerMike Frysinger <vapier@gentoo.org>2009-05-23 21:12:43 +0000
commitbc0e9b54af43b1ce4e00ca23ead3e6b514c71766 (patch)
treeda03ef156b397a931268535f46c4e49831ac1ff8 /sys-apps/util-linux
parentFix build failure when source use flag enabled. (diff)
downloadhistorical-bc0e9b54af43b1ce4e00ca23ead3e6b514c71766.tar.gz
historical-bc0e9b54af43b1ce4e00ca23ead3e6b514c71766.tar.bz2
historical-bc0e9b54af43b1ce4e00ca23ead3e6b514c71766.zip
old
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/util-linux-2.14.1.ebuild94
1 files changed, 0 insertions, 94 deletions
diff --git a/sys-apps/util-linux/util-linux-2.14.1.ebuild b/sys-apps/util-linux/util-linux-2.14.1.ebuild
deleted file mode 100644
index 0009a36346a8..000000000000
--- a/sys-apps/util-linux/util-linux-2.14.1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.14.1.ebuild,v 1.14 2009/02/15 00:19:52 vapier Exp $
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
-inherit eutils
-[[ ${PV} == "9999" ]] && inherit git
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-ng-${MY_PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Various useful Linux utilities"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux-ng/"
-if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
-else
- SRC_URI="mirror://kernel/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2
- loop-aes? ( http://loop-aes.sourceforge.net/updates/util-linux-ng-2.14.1-20081015.diff.bz2 )"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="crypt loop-aes nls old-linux selinux slang uclibc unicode"
-
-RDEPEND="!sys-process/schedutils
- !sys-apps/setarch
- >=sys-libs/ncurses-5.2-r2
- >=sys-libs/e2fsprogs-libs-1.41
- selinux? ( sys-libs/libselinux )
- slang? ( sys-libs/slang )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/os-headers"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git_src_unpack
- cd "${S}"
- ./autogen.sh || die
- else
- unpack ${A}
- cd "${S}"
- #epatch "${FILESDIR}"/${PN}-2.13-uclibc.patch #203711
- epatch "${FILESDIR}"/${PN}-2.14-AC_BIG_ENDIAN.patch
- use loop-aes && epatch "${WORKDIR}"/util-linux-ng-2.14.1-20081015.diff
- epatch "${FILESDIR}"/${PN}-2.13.1-no-a.out.patch #221939
- fi
- use uclibc && sed -i -e s/versionsort/alphasort/g -e s/strverscmp.h/dirent.h/g mount/lomount.c
-}
-
-src_compile() {
- econf \
- --with-fsprobe=blkid \
- $(use_enable nls) \
- --enable-agetty \
- --enable-cramfs \
- $(use_enable old-linux elvtune) \
- --disable-init \
- --disable-kill \
- --disable-last \
- --disable-mesg \
- --enable-partx \
- --enable-raw \
- --enable-rdev \
- --enable-rename \
- --disable-reset \
- --disable-login-utils \
- --enable-schedutils \
- --disable-wall \
- --enable-write \
- --without-pam \
- $(use unicode || echo --with-ncurses) \
- $(use_with selinux) \
- $(use_with slang) \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "install failed"
- dodoc AUTHORS NEWS README* TODO docs/*
-
- if use crypt ; then
- newinitd "${FILESDIR}"/crypto-loop.initd crypto-loop || die
- newconfd "${FILESDIR}"/crypto-loop.confd crypto-loop || die
- fi
-}
-
-pkg_postinst() {
- ewarn "The loop-aes code has been split out of USE=crypt and into USE=loop-aes."
- ewarn "If you need support for it, make sure to update your USE accordingly."
-}