summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2003-03-15 23:25:42 +0000
committerMark Guertin <gerk@gentoo.org>2003-03-15 23:25:42 +0000
commit9551027cc0e426245179f95a390fe6535dbd1475 (patch)
treecefd5a3a6c09ff29fd966160b94436d73dea8d3e /sys-apps/yaboot
parentversion bump (diff)
downloadhistorical-9551027cc0e426245179f95a390fe6535dbd1475.tar.gz
historical-9551027cc0e426245179f95a390fe6535dbd1475.tar.bz2
historical-9551027cc0e426245179f95a390fe6535dbd1475.zip
fixup for yabootconfig bug
Diffstat (limited to 'sys-apps/yaboot')
-rw-r--r--sys-apps/yaboot/ChangeLog9
-rw-r--r--sys-apps/yaboot/files/digest-yaboot-1.3.10-r11
-rw-r--r--sys-apps/yaboot/files/yabootconfig-1.3.10.patch2
-rw-r--r--sys-apps/yaboot/yaboot-1.3.10-r1.ebuild37
4 files changed, 47 insertions, 2 deletions
diff --git a/sys-apps/yaboot/ChangeLog b/sys-apps/yaboot/ChangeLog
index d66c5908ac07..213a635b03e7 100644
--- a/sys-apps/yaboot/ChangeLog
+++ b/sys-apps/yaboot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/yaboot
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/yaboot/ChangeLog,v 1.14 2003/03/11 06:23:14 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/yaboot/ChangeLog,v 1.15 2003/03/15 23:25:42 gerk Exp $
+
+*yaboot-1.3.10-r1 (15 Mar 2003)
+
+ 15 Mar 2003; Mark Guertin <gerk@gentoo.org> yaboot-1.3.10-r1.ebuild,
+ files/yabootconfig-1.3.10.patch:
+ fixed typo in yabootconfig which caused invalid macosx= in yaboot.conf, rev
+ bumped to ensure people update
*yaboot-1.3.10 (26 Feb 2003)
diff --git a/sys-apps/yaboot/files/digest-yaboot-1.3.10-r1 b/sys-apps/yaboot/files/digest-yaboot-1.3.10-r1
new file mode 100644
index 000000000000..89c08fc0aa93
--- /dev/null
+++ b/sys-apps/yaboot/files/digest-yaboot-1.3.10-r1
@@ -0,0 +1 @@
+MD5 9770dc5128b2aa45d16d2002a9565002 yaboot-1.3.10.tar.gz 273454
diff --git a/sys-apps/yaboot/files/yabootconfig-1.3.10.patch b/sys-apps/yaboot/files/yabootconfig-1.3.10.patch
index c9de2c10782f..a6824f524517 100644
--- a/sys-apps/yaboot/files/yabootconfig-1.3.10.patch
+++ b/sys-apps/yaboot/files/yabootconfig-1.3.10.patch
@@ -49,7 +49,7 @@
+if [ -n "$MACOS" ] ; then
+ MACOSBOOT="macos=${MACOS}\n"
+fi
-+if [ -n "OSX" ] ; then
++if [ -n "$OSX" ] ; then
+ OSXBOOT="macosx=${OSX}\n"
+fi
+
diff --git a/sys-apps/yaboot/yaboot-1.3.10-r1.ebuild b/sys-apps/yaboot/yaboot-1.3.10-r1.ebuild
new file mode 100644
index 000000000000..f472d297b0e3
--- /dev/null
+++ b/sys-apps/yaboot/yaboot-1.3.10-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/yaboot/yaboot-1.3.10-r1.ebuild,v 1.1 2003/03/15 23:25:42 gerk Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PPC Bootloader"
+SRC_URI="http://penguinppc.org/projects/yaboot/${P}.tar.gz"
+HOMEPAGE="http://penguinppc.org/projects/yaboot/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="ppc -x86 -sparc -alpha"
+
+DEPEND="sys-apps/powerpc-utils
+ sys-apps/hfsutils
+ sys-apps/hfsplusutils"
+
+PROVIDE="virtual/bootloader"
+
+MAKEOPTS='PREFIX=/usr MANDIR=share/man'
+
+src_compile() {
+ export -n CFLAGS
+ export -n CXXFLAGS
+ # dual boot patch
+ epatch ${FILESDIR}/yabootconfig-${PV}.patch
+ emake ${MAKEOPTS} || die
+}
+
+src_install() {
+ cp etc/yaboot.conf etc/yaboot.conf.bak
+ sed -e 's/\/local//' etc/yaboot.conf >| etc/yaboot.conf.edit
+ mv -f etc/yaboot.conf.edit etc/yaboot.conf
+ make ROOT=${D} ${MAKEOPTS} install || die
+}