summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-20 14:22:43 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-20 14:22:43 +0000
commit52dcf3b408838c1a3ba0430b30867d237202549b (patch)
treea943c58b130c2c50455f07ab625a405f1dce5124 /sys-apps
parentupdated binutils mask from 2.11.x to 2.13.x (diff)
downloadhistorical-52dcf3b408838c1a3ba0430b30867d237202549b.tar.gz
historical-52dcf3b408838c1a3ba0430b30867d237202549b.tar.bz2
historical-52dcf3b408838c1a3ba0430b30867d237202549b.zip
Closes #10736.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iptables/ChangeLog5
-rw-r--r--sys-apps/iptables/files/iptables-1.2.7a-gentoo.diff23
-rw-r--r--sys-apps/iptables/iptables-1.2.7a.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/sys-apps/iptables/ChangeLog b/sys-apps/iptables/ChangeLog
index f66a186220ba..0a4efa25cf24 100644
--- a/sys-apps/iptables/ChangeLog
+++ b/sys-apps/iptables/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for sys-apps/iptables
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/ChangeLog,v 1.12 2002/09/25 13:38:02 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/ChangeLog,v 1.13 2002/11/20 14:22:43 aliz Exp $
*iptables-1.2.7a (27 Aug 2002)
+ 20 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> iptables-1.2.7a.ebuild :
+ Added patch for iptables-restore. Contributed by fridtjof@fbunet.de in #10736.
+
25 Sep 2002; Daniel Ahlberg <aliz@gentoo.org> files/iptables-1.2.7a-imq.diff-3 :
Closes #8046.
diff --git a/sys-apps/iptables/files/iptables-1.2.7a-gentoo.diff b/sys-apps/iptables/files/iptables-1.2.7a-gentoo.diff
new file mode 100644
index 000000000000..f6235bfdfb9c
--- /dev/null
+++ b/sys-apps/iptables/files/iptables-1.2.7a-gentoo.diff
@@ -0,0 +1,23 @@
+--- extensions/libipt_mac.c.orig Fri Nov 8 18:20:48 2002
++++ extensions/libipt_mac.c Fri Nov 8 18:22:48 2002
+@@ -90,7 +90,7 @@
+ {
+ unsigned int i;
+
+- printf("%s%02X", invert ? "!" : "", macaddress[0]);
++ printf("%s %02X", invert ? "!" : "", macaddress[0]);
+ for (i = 1; i < ETH_ALEN; i++)
+ printf(":%02X", macaddress[i]);
+ printf(" ");
+--- extensions/libip6t_mac.c.orig Fri Nov 8 18:23:10 2002
++++ extensions/libip6t_mac.c Fri Nov 8 18:23:31 2002
+@@ -90,7 +90,7 @@
+ {
+ unsigned int i;
+
+- printf("%s%02X", invert ? "!" : "", macaddress[0]);
++ printf("%s %02X", invert ? "!" : "", macaddress[0]);
+ for (i = 1; i < ETH_ALEN; i++)
+ printf(":%02X", macaddress[i]);
+ printf(" ");
+
diff --git a/sys-apps/iptables/iptables-1.2.7a.ebuild b/sys-apps/iptables/iptables-1.2.7a.ebuild
index 945e552dcb2d..e3d9870002d3 100644
--- a/sys-apps/iptables/iptables-1.2.7a.ebuild
+++ b/sys-apps/iptables/iptables-1.2.7a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/iptables-1.2.7a.ebuild,v 1.9 2002/10/20 18:54:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/iptables-1.2.7a.ebuild,v 1.10 2002/11/20 14:22:43 aliz Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Kernel 2.4 firewall, NAT and packet mangling tools"
@@ -16,6 +16,7 @@ src_unpack() {
unpack ${A}
cd ${S}
patch -p1 < ${FILESDIR}/${P}-imq.diff-3 || die
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff || die
chmod +x extensions/.IMQ-test*
mv Makefile Makefile.orig
sed -e "s/-O2/${CFLAGS}/g" -e "s:/usr/local::g" Makefile.orig > Makefile