summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-03-03 08:01:47 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-03-03 08:01:47 +0000
commit6bcd1c471c55f59296b3e95e1b6da48c36b13197 (patch)
tree8d0b4d2f756a129378c005280fee7c9d0e3a2900 /sys-apps
parentminor change - use $T (diff)
downloadhistorical-6bcd1c471c55f59296b3e95e1b6da48c36b13197.tar.gz
historical-6bcd1c471c55f59296b3e95e1b6da48c36b13197.tar.bz2
historical-6bcd1c471c55f59296b3e95e1b6da48c36b13197.zip
new mosix-user ebuild. Getting ready to add openmosix support.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/mosix-user/files/digest-mosix-user-1.5.71
-rw-r--r--sys-apps/mosix-user/mosix-user-1.5.7.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/mosix-user/files/digest-mosix-user-1.5.7 b/sys-apps/mosix-user/files/digest-mosix-user-1.5.7
new file mode 100644
index 000000000000..e62668b7a60e
--- /dev/null
+++ b/sys-apps/mosix-user/files/digest-mosix-user-1.5.7
@@ -0,0 +1 @@
+MD5 0609e667fa713f0f14b2f21d96e01c15 MOSIX-1.5.7.tar.gz 394854
diff --git a/sys-apps/mosix-user/mosix-user-1.5.7.ebuild b/sys-apps/mosix-user/mosix-user-1.5.7.ebuild
new file mode 100644
index 000000000000..483cd19c2553
--- /dev/null
+++ b/sys-apps/mosix-user/mosix-user-1.5.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/sys-apps/mosix-user/mosix-user-1.5.2.ebuild,v 1.4 2001/11/25 02:40:12 drobbins Exp
+
+S=${WORKDIR}/user
+DESCRIPTION="User-land utilities for MOSIX process migration (clustering) software"
+SRC_URI="http://www.mosix.cs.huji.ac.il/ftps/MOSIX-${PV}.tar.gz"
+HOMEPAGE="http://www.mosix.org"
+DEPEND="virtual/glibc >=sys-libs/ncurses-5.2"
+
+src_unpack() {
+ mkdir ${S}; cd ${S}
+ tar -xz --no-same-owner -f ${DISTDIR}/${A} MOSIX-${PV}/user.tar MOSIX-${PV}/manuals.tar
+ mv MOSIX-${PV}/*.tar .
+ rm -rf MOSIX-${PV}
+ tar -x --no-same-owner -f user.tar -C ${S}
+ tar -x --no-same-owner -f manuals.tar -C ${S}
+}
+
+src_compile() {
+ cd ${S}
+ local x
+ for x in lib/moslib sbin/setpe sbin/tune bin/mosrun usr.bin/mon usr.bin/migrate usr.bin/mosctl
+ do
+ cd $x
+ make || die
+ cd ../..
+ done
+}
+
+src_install () {
+ cd ${S}
+ make ROOT=${D} PREFIX=${D}/usr install
+ dodir /usr/share
+ cd ${D}/usr
+ mv man share
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/mosix.init mosix
+ insinto /etc
+ #stub mosix.map file
+ doins ${FILESDIR}/mosix.map
+ cd ${S}
+ doman man?/*
+}
+
+pkg_postinst() {
+ echo
+ echo " To complete MOSIX installation, edit /etc/mosix.map and then type:
+ echo "# rc-update add mosix default
+ echo " ...to add MOSIX to the default runlevel. This particular version of"
+ echo " mosix-user has been designed to work with the 2.4.13 kernel."
+ echo
+}