summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-03-20 12:25:23 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-03-20 12:25:23 +0000
commitc69a493669571623d1fb98abd86bc6b65841b047 (patch)
treec16cca926fd238afe0f0083900495422afee7cde /sys-apps
parentgnome 2.6 commit (diff)
downloadhistorical-c69a493669571623d1fb98abd86bc6b65841b047.tar.gz
historical-c69a493669571623d1fb98abd86bc6b65841b047.tar.bz2
historical-c69a493669571623d1fb98abd86bc6b65841b047.zip
Version bump. Closing #45072.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/qingy/ChangeLog7
-rw-r--r--sys-apps/qingy/Manifest6
-rw-r--r--sys-apps/qingy/files/digest-qingy-0.4.01
-rw-r--r--sys-apps/qingy/qingy-0.4.0.ebuild57
4 files changed, 68 insertions, 3 deletions
diff --git a/sys-apps/qingy/ChangeLog b/sys-apps/qingy/ChangeLog
index 95843e46a329..cf2394f56726 100644
--- a/sys-apps/qingy/ChangeLog
+++ b/sys-apps/qingy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/qingy
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.7 2004/02/25 06:35:01 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.8 2004/03/20 12:25:23 pyrania Exp $
+
+*qingy-0.4.0 (20 Mar 2004)
+
+ 20 Mar 2004; Markus Nigbur <pyrania@gentoo.org> qingy-0.4.0.ebuild:
+ Version bump. Closing #45072.
*qingy-0.3.0 (25 Feb 2004)
diff --git a/sys-apps/qingy/Manifest b/sys-apps/qingy/Manifest
index 84bac3c9c3e8..9532fdcd8101 100644
--- a/sys-apps/qingy/Manifest
+++ b/sys-apps/qingy/Manifest
@@ -1,10 +1,12 @@
MD5 718addc24aa6c1221c830a98fa280bcb qingy-0.2.2.ebuild 1082
-MD5 7354d22c81c81f0aed924c38b87021d8 qingy-0.3.0.ebuild 1223
+MD5 f1991689916d7f7ecbc25977b021fa12 qingy-0.3.0.ebuild 1322
+MD5 8c72e2ce3cbb92667865ebea720eefed qingy-0.4.0.ebuild 1931
MD5 23d06b5fe758af33f0f651982432a418 qingy-0.2.1.ebuild 1081
MD5 3d6f42987d859def1e1edc06ecf567c6 qingy-0.2.3.ebuild 1111
-MD5 f0c135a7dbf6779a918503daea41e49a ChangeLog 1058
+MD5 9209def3cd9b3432517f7e7e3e63460d ChangeLog 1189
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 d2c2a387643e5c0930982bbc58adb529 files/digest-qingy-0.2.1 64
MD5 eea835254d6473eb82299eca77e9f219 files/digest-qingy-0.2.2 64
MD5 c3008d48a523b5f16a29469f4f29de27 files/digest-qingy-0.2.3 64
MD5 91a37fa2bb3a93238c23672eff9c4dca files/digest-qingy-0.3.0 64
+MD5 734ceb39541dd6aee2025617d8548ed8 files/digest-qingy-0.4.0 64
diff --git a/sys-apps/qingy/files/digest-qingy-0.4.0 b/sys-apps/qingy/files/digest-qingy-0.4.0
new file mode 100644
index 000000000000..211e52ee625d
--- /dev/null
+++ b/sys-apps/qingy/files/digest-qingy-0.4.0
@@ -0,0 +1 @@
+MD5 31f708e4e824c5fc17d5a42eb09357f5 qingy-0.4.0.tar.bz2 474606
diff --git a/sys-apps/qingy/qingy-0.4.0.ebuild b/sys-apps/qingy/qingy-0.4.0.ebuild
new file mode 100644
index 000000000000..130b33d8c794
--- /dev/null
+++ b/sys-apps/qingy/qingy-0.4.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.4.0.ebuild,v 1.1 2004/03/20 12:25:23 pyrania Exp $
+
+DESCRIPTION="Qingy is a DirectFB getty replacement."
+HOMEPAGE="http://qingy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="emacs pam static"
+DEPEND=">=dev-libs/DirectFB-0.9.18
+ emacs? ( virtual/emacs )
+ pam? ( >=sys-libs/pam-0.75-r11 )
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile()
+{
+ # override qingy self-calculated cflags, honour USE flags
+ econf MY_CFLAGS="${CFLAGS}" \
+ `use_enable emacs` \
+ `use_enable pam` \
+ `use_enable static static-build` \
+ || die "Configuration failed"
+
+ # if prefix="/" is omitted, after installation qingy
+ # will not be able to find its shared libraries
+ emake prefix="/" || die "Compilation failed"
+}
+
+src_install()
+{
+ # copy documentation manually as make install only installs info files
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
+
+ # and finally install the program
+ einstall prefix=${D} || die "Installation failed"
+}
+
+pkg_postinst()
+{
+ einfo "In order to use qingy you must first edit your /etc/inittab"
+ einfo "Check files INSTALL and README in /usr/share/doc/${P}"
+ einfo "for instructions on how to do that. Or issue an 'info qingy'."
+ echo
+ ewarn "Please note that configuration and theme files syntax"
+ ewarn "has changed since version 0.2x: please remove all"
+ ewarn "old themes and update qingy configuration files!"
+ echo
+ einfo "Note that since version 0.4x themes are located in"
+ einfo "/usr/share/qingy/themes and screensavers in"
+ einfo "/usr/lib/qingy/screensavers"
+ echo
+ einfo "You can safely remove /etc/directfbrc.qingy"
+ einfo "as it is no longer needed to get framebuffer resolution"
+ sleep 5
+}