summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2010-02-08 03:03:29 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2010-02-08 03:03:29 +0000
commitd931baddceda15bb8b0b548e70bfa0eca19e6e9d (patch)
tree1406badc2b80be86f07fc49149156e47465ca6f2 /sys-auth
parentapp-portage/layman: Add missing "inherit eutils" for epause (bug #303849) (diff)
downloadhistorical-d931baddceda15bb8b0b548e70bfa0eca19e6e9d.tar.gz
historical-d931baddceda15bb8b0b548e70bfa0eca19e6e9d.tar.bz2
historical-d931baddceda15bb8b0b548e70bfa0eca19e6e9d.zip
Initial commit. PulseAudio should start using this soon.
Package-Manager: portage-2.2_rc62/cvs/Linux x86_64
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/rtkit/ChangeLog10
-rw-r--r--sys-auth/rtkit/Manifest4
-rw-r--r--sys-auth/rtkit/metadata.xml14
-rw-r--r--sys-auth/rtkit/rtkit-0.6.ebuild42
4 files changed, 70 insertions, 0 deletions
diff --git a/sys-auth/rtkit/ChangeLog b/sys-auth/rtkit/ChangeLog
new file mode 100644
index 000000000000..c23fea15c130
--- /dev/null
+++ b/sys-auth/rtkit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-auth/rtkit
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/rtkit/ChangeLog,v 1.1 2010/02/08 03:03:29 ford_prefect Exp $
+
+*rtkit-0.6 (08 Feb 2010)
+
+ 08 Feb 2010; Arun Raghavan <ford_prefect@gentoo.org> +rtkit-0.6.ebuild,
+ +metadata.xml:
+ Initial commit. PulseAudio should start using this soon.
+
diff --git a/sys-auth/rtkit/Manifest b/sys-auth/rtkit/Manifest
new file mode 100644
index 000000000000..d194151ee99b
--- /dev/null
+++ b/sys-auth/rtkit/Manifest
@@ -0,0 +1,4 @@
+DIST rtkit-0.6.tar.gz 149270 RMD160 32a97e369cef07353efb7046b336eb09f5868834 SHA1 0b1b6e58817f9bd6fceb66ab124f7293af9e3c9b SHA256 1077d78aa12fdd802a7ec38fcf8eaaebbdfc1b705340b3c02db32882f644f196
+EBUILD rtkit-0.6.ebuild 1071 RMD160 aadde188096e0245befccf6cb12bcd81263314fa SHA1 813d07f5c5cfb526d95b6150306cc991f7a5391d SHA256 fe69866712e805efc02fb14492f0bf3d338db97279661ba4bcbb1513bf3e9244
+MISC ChangeLog 384 RMD160 f1d7262955e0067cc1965f4c9e16570d735a08bf SHA1 4f77a7b52e1b9f7f373de4c18c0223ef563f1bf2 SHA256 89eee966d7cd5ef4a3ec0dfa7db3cc9c401b7d8838a087d0f8bd254a79fb94d0
+MISC metadata.xml 485 RMD160 59804277917b2fc4fa4849ef78d257d1e2e9a2f4 SHA1 133800efc9401ec6f9c370eb2a53b474ae354d02 SHA256 9fb49fa7b691f907e87651f17ede971f5135171418d4530adb8db13d26934b48
diff --git a/sys-auth/rtkit/metadata.xml b/sys-auth/rtkit/metadata.xml
new file mode 100644
index 000000000000..2b23994c7e32
--- /dev/null
+++ b/sys-auth/rtkit/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>ford_prefect@gentoo.org</email>
+ <name>Arun Raghavan</name>
+ </maintainer>
+ <longdescription lang="en">
+ RealtimeKit is a DBus service that provides applications with an interface
+ to escalate their priority to realtime, without any special setup in
+ rlimits, etc.
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-auth/rtkit/rtkit-0.6.ebuild b/sys-auth/rtkit/rtkit-0.6.ebuild
new file mode 100644
index 000000000000..9d5422bd00d9
--- /dev/null
+++ b/sys-auth/rtkit/rtkit-0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/rtkit/rtkit-0.6.ebuild,v 1.1 2010/02/08 03:03:29 ford_prefect Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Realtime Policy and Watchdog Daemon"
+HOMEPAGE="http://0pointer.de/blog/projects/rtkit"
+SRC_URI="http://0pointer.de/public/${P}.tar.gz"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/dbus
+ sys-auth/polkit
+ sys-libs/libcap"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup rtkit
+ enewuser rtkit -1 -1 -1 "rtkit"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install"
+
+ ./rtkit-daemon --introspection > org.freedesktop.RealtimeKit1.xml
+ insinto /usr/share/dbus-1/interfaces
+ doins org.freedesktop.RealtimeKit1.xml
+}
+
+pkg_postinst () {
+ einfo "To start using RealtimeKit, you need to ensure that the 'dbus'"
+ einfo "service is running. If it is already running, you need to reload it"
+ einfo "with the following command:"
+ einfo ""
+ einfo " /etc/init.d/dbus reload"
+}