summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-01-14 01:56:05 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-01-14 01:56:05 +0000
commit6acfa7a57899b759717ea5f7de5648c7ec915c2e (patch)
tree9e9e72f21d76da3b06392dab45ade6ab8c228b4d /sys-block/scsirastools/scsirastools-1.5.6.ebuild
parentVersion bump, and send to base-system. (diff)
downloadhistorical-6acfa7a57899b759717ea5f7de5648c7ec915c2e.tar.gz
historical-6acfa7a57899b759717ea5f7de5648c7ec915c2e.tar.bz2
historical-6acfa7a57899b759717ea5f7de5648c7ec915c2e.zip
Remove old ebuild, clean up existing, version bump for sysfs scanning stuff.
Package-Manager: portage-2.1.4
Diffstat (limited to 'sys-block/scsirastools/scsirastools-1.5.6.ebuild')
-rw-r--r--sys-block/scsirastools/scsirastools-1.5.6.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sys-block/scsirastools/scsirastools-1.5.6.ebuild b/sys-block/scsirastools/scsirastools-1.5.6.ebuild
new file mode 100644
index 000000000000..58c34b807609
--- /dev/null
+++ b/sys-block/scsirastools/scsirastools-1.5.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/scsirastools/scsirastools-1.5.6.ebuild,v 1.1 2008/01/14 01:56:04 robbat2 Exp $
+
+inherit autotools
+
+DESCRIPTION="Serviceability for SCSI Disks and Arrays"
+HOMEPAGE="http://scsirastools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+DEPEND="virtual/libc
+ sys-apps/rescan-scsi-bus
+ sys-apps/sg3_utils"
+#RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ # this builds a really old mdadm
+ sed -i \
+ -e '/RPMB/d' \
+ -e '/^SUBDIRS/s,mdadm.d,,' \
+ -e '/^SUBDIRS/s,files,,' \
+ "${S}"/Makefile.am || die "sed Makefile.am failed"
+ cd "${S}"
+ eautoreconf
+ # i386 ELF binaries in tarball = bad
+ rm -f "${S}"/files/alarms*
+
+ # Fix up /sbin instances to be /usr/sbin instead
+ for i in src/sgraidmon.c src/sgdiskmon.c ; do
+ sed -i "${S}"/${i} \
+ -e '/evtcmd\[\].*\"\/sbin\//s,/sbin/,/usr/sbin/,' \
+ || die "Failed to set /sbin in sources"
+ done
+}
+
+src_compile() {
+ econf --sbindir=/usr/sbin \
+ || die "econf failed"
+ emake \
+ || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ docdir="/usr/share/doc/${PF}/"
+ emake install DESTDIR="${D}" datato="${D}${docdir}" \
+ || "emake install failed"
+ dosbin files/sgevt
+ dosbin files/mdevt
+ # unneeded files
+ rm -f "${D}"${docdir}/{SCSIRAS,COPYING}
+ # install modepage files
+ insinto /usr/share/${PN}
+ doins files/*.mdf
+ # new docs
+ dodoc ChangeLog AUTHORS TODO
+ # ensure that other docs from the emake install are compressed too.
+ prepalldocs
+}