summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-12-16 02:34:37 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-12-16 02:34:37 +0000
commite62f1ae0c5e37648350edd1b0bd6c95a397e45da (patch)
tree340178be972e6f884f257f3ec95dd8c7ea2f6b93 /sys-boot/grub/grub-0.92-r1.ebuild
parentmove the patches to the mirrors isntead, and add the gcc3.3 patch to 0.92 as ... (diff)
downloadhistorical-e62f1ae0c5e37648350edd1b0bd6c95a397e45da.tar.gz
historical-e62f1ae0c5e37648350edd1b0bd6c95a397e45da.tar.bz2
historical-e62f1ae0c5e37648350edd1b0bd6c95a397e45da.zip
move the patches to the mirrors isntead, and add the gcc3.3 patch to 0.92 as well
Diffstat (limited to 'sys-boot/grub/grub-0.92-r1.ebuild')
-rw-r--r--sys-boot/grub/grub-0.92-r1.ebuild36
1 files changed, 14 insertions, 22 deletions
diff --git a/sys-boot/grub/grub-0.92-r1.ebuild b/sys-boot/grub/grub-0.92-r1.ebuild
index 0f536d7a8cc8..c893bca87da6 100644
--- a/sys-boot/grub/grub-0.92-r1.ebuild
+++ b/sys-boot/grub/grub-0.92-r1.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.92-r1.ebuild,v 1.1 2003/12/09 08:12:07 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.92-r1.ebuild,v 1.2 2003/12/16 02:34:31 seemant Exp $
-inherit mount-boot eutils flag-o-matic
+inherit mount-boot eutils flag-o-matic gcc
filter-flags "-fstack-protector"
+PATCHVER=0.1
S=${WORKDIR}/${P}
DESCRIPTION="GNU GRUB boot loader"
-SRC_URI="ftp://alpha.gnu.org/gnu/grub/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/grub/"
+SRC_URI="ftp://alpha.gnu.org/gnu/grub/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo-${PATCHVER}.tar.bz2
+ http://dev.gentoo.org/~seemant/extras/${P}-gentoo-${PATCHVER}.tar.bz2"
SLOT="0"
LICENSE="GPL-2"
@@ -20,25 +23,14 @@ DEPEND=">=sys-libs/ncurses-5.2-r5"
PROVIDE="virtual/bootloader"
src_unpack() {
- unpack ${A} || die
- cd ${S} || die
- epatch ${FILESDIR}/${P}/grub-0.92-vga16.patch
- epatch ${FILESDIR}/${P}/grub-0.5.96.1-special-raid-devices.patch
- epatch ${FILESDIR}/${P}/grub-0.90-configfile.patch
- epatch ${FILESDIR}/${P}/grub-0.90-vga16-keypressclear.patch
- epatch ${FILESDIR}/${P}/grub-0.90-passwordprompt.patch
- epatch ${FILESDIR}/${P}/grub-0.90-install.in.patch
- epatch ${FILESDIR}/${P}/grub-0.90-installcopyonly.patch
- epatch ${FILESDIR}/${P}/grub-0.90-staticcurses.patch
- epatch ${FILESDIR}/${P}/grub-0.90-symlinkmenulst.patch
- epatch ${FILESDIR}/${P}/grub-0.90-append.patch
- epatch ${FILESDIR}/${P}/grub-0.90-addsyncs.patch
- epatch ${FILESDIR}/${P}/grub-0.91-splashimagehelp.patch
- epatch ${FILESDIR}/${P}/grub-0.91-bootonce.patch
- epatch ${FILESDIR}/${P}/grub-0.92-automake16.patch
- epatch ${FILESDIR}/${P}/grub-0.92-nodeprecatedflags.patch
- epatch ${FILESDIR}/${P}/grub-0.91-vga16-serial.patch
- epatch ${FILESDIR}/${P}/grub-0.92-usbfix.patch
+ unpack ${A}
+ cd ${S}
+ EPATCH_SUFFIX="patch" epatch ${WORKDIR}/patch
+
+ if [ "`gcc-version`" = "3.3" ]
+ then
+ epatch ${FILESDIR}/grub-0.93-gcc3.3.diff
+ fi
}
src_compile() {