summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-07-15 11:34:38 +0000
committerMichael Weber <xmw@gentoo.org>2013-07-15 11:34:38 +0000
commit5673d69db6084017503d153a6d1c0e2caeb6c057 (patch)
tree909692d9ea6527c58d54f7832c70e3d7194ebbca /sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130711.ebuild
parentgperf is a harrdep again, due to changes made by upstream in git (diff)
downloadhistorical-5673d69db6084017503d153a6d1c0e2caeb6c057.tar.gz
historical-5673d69db6084017503d153a6d1c0e2caeb6c057.tar.bz2
historical-5673d69db6084017503d153a6d1c0e2caeb6c057.zip
Protect existing cmdline.txt & config.txt, add files dir (thanks chithead and Pim Vullers, bug 476896).
Package-Manager: portage-2.2.0_alpha188/cvs/Linux x86_64 Manifest-Sign-Key: 0x62EEF090
Diffstat (limited to 'sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130711.ebuild')
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130711.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130711.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130711.ebuild
index 86f88bb29569..54a3a8cf157d 100644
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130711.ebuild
+++ b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130711.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130711.ebuild,v 1.1 2013/07/15 06:58:46 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130711.ebuild,v 1.2 2013/07/15 11:34:34 xmw Exp $
EAPI=5
@@ -28,15 +28,23 @@ RESTRICT="binchecks strip"
src_unpack() { :; }
+pkg_preinst() {
+ if [ -z "${REPLACING_VERSIONS}" ] ; then
+ if [ -e /boot/cmdline.txt -o -e /boot/config.txt ] ; then
+ die "Please backup and remove /boot/cmdline.txt and /boot/config.txt to and merge configs after installation."
+ fi
+ fi
+}
+
src_install() {
insinto /boot
local a
for a in ${A} ; do
- newins "${DISTDIR}"/${a} ${a#${P}-}
+ newins "${DISTDIR}"/${a} ${a#${PN}-${MY_COMMIT}-}
done
- newins "${FILESDIR}"/${P}-config.txt config.txt
- newins "${FILESDIR}"/${P}-cmdline.txt cmdline.txt
- newenvd "${FILESDIR}"/${P}-envd 90${PN}
+ newins "${FILESDIR}"/${PN}-0_p20130711-config.txt config.txt
+ newins "${FILESDIR}"/${PN}-0_p20130711-cmdline.txt cmdline.txt
+ newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
readme.gentoo_create_doc
}