summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2008-03-17 16:26:21 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2008-03-17 16:26:21 +0000
commitdbf49db307997aa84a7d459b7a83582b4ba72273 (patch)
treed4a13420c34872d8aa9cd39809e3db9e64974ba4 /sys-cluster/dlm-lib
parentInitial Import. (diff)
downloadhistorical-dbf49db307997aa84a7d459b7a83582b4ba72273.tar.gz
historical-dbf49db307997aa84a7d459b7a83582b4ba72273.tar.bz2
historical-dbf49db307997aa84a7d459b7a83582b4ba72273.zip
Initial import.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'sys-cluster/dlm-lib')
-rw-r--r--sys-cluster/dlm-lib/ChangeLog11
-rw-r--r--sys-cluster/dlm-lib/dlm-lib-2.02.00.ebuild62
-rw-r--r--sys-cluster/dlm-lib/files/dlm-lib-2.02.00-include.patch20
-rw-r--r--sys-cluster/dlm-lib/metadata.xml8
4 files changed, 101 insertions, 0 deletions
diff --git a/sys-cluster/dlm-lib/ChangeLog b/sys-cluster/dlm-lib/ChangeLog
new file mode 100644
index 000000000000..44d4f7785bcf
--- /dev/null
+++ b/sys-cluster/dlm-lib/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-cluster/dlm-lib
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/dlm-lib/ChangeLog,v 1.1 2008/03/17 16:26:21 xmerlin Exp $
+
+*dlm-lib-2.02.00 (17 Mar 2008)
+
+ 17 Mar 2008; Christian Zoffoli <xmerlin@gentoo.org>
+ +files/dlm-lib-2.02.00-include.patch, +metadata.xml,
+ +dlm-lib-2.02.00.ebuild:
+ Initial Import
+
diff --git a/sys-cluster/dlm-lib/dlm-lib-2.02.00.ebuild b/sys-cluster/dlm-lib/dlm-lib-2.02.00.ebuild
new file mode 100644
index 000000000000..497978637c11
--- /dev/null
+++ b/sys-cluster/dlm-lib/dlm-lib-2.02.00.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/dlm-lib/dlm-lib-2.02.00.ebuild,v 1.1 2008/03/17 16:26:21 xmerlin Exp $
+
+inherit eutils versionator
+
+CLUSTER_RELEASE="${PV}"
+MY_P="cluster-${CLUSTER_RELEASE}"
+
+MAJ_PV="$(get_major_version)"
+MIN_PV="$(get_version_component_range 2).$(get_version_component_range 3)"
+
+DESCRIPTION="General-purpose Distributed Lock Manager"
+HOMEPAGE="http://sources.redhat.com/cluster/"
+SRC_URI="ftp://sources.redhat.com/pub/cluster/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-kernel/linux-headers-2.6.23
+ !sys-cluster/dlm-headers
+ !sys-cluster/dlm-kernel
+ "
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/${PN/-//}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix the manual pages have executable bit
+ #sed -i -e '
+ # /\tinstall -d/s/install/& -m 0755/; t
+ # /\tinstall/s/install/& -m 0644/' \
+ # man/Makefile || die "failed patching man pages permission"
+
+ epatch "${FILESDIR}"/${P}-include.patch || die
+}
+
+src_compile() {
+ (cd "${WORKDIR}"/${MY_P};
+ ./configure \
+ --cc=$(tc-getCC) \
+ --cflags="-Wall" \
+ --disable_kernel_check \
+ --release_major="$MAJ_PV" \
+ --release_minor="$MIN_PV" \
+ --cmanlibdir=/usr/lib \
+ --cmanincdir=/usr/include \
+ ) || die "configure problem"
+
+ #emake clean || die "clean problem"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install problem"
+}
diff --git a/sys-cluster/dlm-lib/files/dlm-lib-2.02.00-include.patch b/sys-cluster/dlm-lib/files/dlm-lib-2.02.00-include.patch
new file mode 100644
index 000000000000..dc7832e682b7
--- /dev/null
+++ b/sys-cluster/dlm-lib/files/dlm-lib-2.02.00-include.patch
@@ -0,0 +1,20 @@
+--- cluster-2.02.00/dlm/lib/Makefile.orig 2008-03-16 15:40:43.000000000 +0000
++++ cluster-2.02.00/dlm/lib/Makefile 2008-03-16 15:40:52.000000000 +0000
+@@ -13,6 +13,8 @@
+
+ TARGET= libdlm
+
++include ../../make/defines.mk
++
+ LIBDIRT=$(TARGET).a \
+ $(TARGET)_lt.a \
+ $(TARGET).so.${RELEASE_MAJOR}.${RELEASE_MINOR} \
+@@ -27,8 +29,6 @@
+
+ UDEVT=51-dlm.rules
+
+-include ../../make/defines.mk
+-
+ SHAREDLIB=$(TARGET).so.${RELEASE_MAJOR}.${RELEASE_MINOR} $(TARGET)_lt.so.${RELEASE_MAJOR}.${RELEASE_MINOR}
+ STATICLIB=$(TARGET).a $(TARGET)_lt.a
+
diff --git a/sys-cluster/dlm-lib/metadata.xml b/sys-cluster/dlm-lib/metadata.xml
new file mode 100644
index 000000000000..b2c73e8f3872
--- /dev/null
+++ b/sys-cluster/dlm-lib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ha-cluster</herd>
+<maintainer>
+ <email>ha-cluster@gentoo.org</email>
+</maintainer>
+</pkgmetadata>