summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2004-09-01 19:58:50 +0000
committerMichael Imhof <tantive@gentoo.org>2004-09-01 19:58:50 +0000
commitea0938943fbf5c05bd641acdcb58515f452eaf9c (patch)
tree5754e07a4505e6012cbebfdaeccb2cf63b19c711 /sys-cluster/saru
parentFix div0 bug #61681 thanks to James <James@superbug.demon.co.uk>. (diff)
downloadhistorical-ea0938943fbf5c05bd641acdcb58515f452eaf9c.tar.gz
historical-ea0938943fbf5c05bd641acdcb58515f452eaf9c.tar.bz2
historical-ea0938943fbf5c05bd641acdcb58515f452eaf9c.zip
more cleanups...
Diffstat (limited to 'sys-cluster/saru')
-rw-r--r--sys-cluster/saru/ChangeLog5
-rw-r--r--sys-cluster/saru/Manifest10
-rw-r--r--sys-cluster/saru/saru-0.0.1.ebuild72
3 files changed, 43 insertions, 44 deletions
diff --git a/sys-cluster/saru/ChangeLog b/sys-cluster/saru/ChangeLog
index ec6912d17948..de08ed782467 100644
--- a/sys-cluster/saru/ChangeLog
+++ b/sys-cluster/saru/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/saru
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/saru/ChangeLog,v 1.2 2004/09/01 19:46:46 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/saru/ChangeLog,v 1.3 2004/09/01 19:58:50 tantive Exp $
+
+ 01 Sep 2004; Michael Imhof <tantive@gentoo.org> saru-0.0.1.ebuild:
+ more cleanups...
01 Sep 2004; Michael Imhof <tantive@gentoo.org> saru-0.0.1.ebuild:
cleaned up the ebuild...
diff --git a/sys-cluster/saru/Manifest b/sys-cluster/saru/Manifest
index 89b98060722a..361f13145580 100644
--- a/sys-cluster/saru/Manifest
+++ b/sys-cluster/saru/Manifest
@@ -1,15 +1,15 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 caba33b42a4e13d13f3aaf49d83e2add saru-0.0.1.ebuild 2391
-MD5 0289ed28cd1402802b36e65bd8e783d6 ChangeLog 472
+MD5 e92aadd1d9a1e537cb4739bb88d9a1e4 saru-0.0.1.ebuild 2583
+MD5 62178998a0b164e2b944d590bc2646d5 ChangeLog 561
MD5 137dd5a4f89430782c03c2c3068ad7f9 files/saru.conf 11
MD5 c5e666d281f435e2d695c302b5716503 files/saru.init 904
MD5 40d70f0580743972bfc3da261b384cc2 files/digest-saru-0.0.1 62
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)
-iD8DBQFBNieLKtJO8LeSoosRAtKzAJ9t8fDLb9bw63Xp7gGihk44jY/DxACfYByV
-TV/Da7x2+fhHVz8I2py4bRs=
-=Wx5g
+iD8DBQFBNiphKtJO8LeSoosRAgqfAJ9vL7sikAgYwyBH2LjXL3iMxZwTjgCfYOcX
+csZKI2W2HNaU0ltYlexyX1Q=
+=wmIv
-----END PGP SIGNATURE-----
diff --git a/sys-cluster/saru/saru-0.0.1.ebuild b/sys-cluster/saru/saru-0.0.1.ebuild
index d1ef335bcfa4..80a938d6ae9c 100644
--- a/sys-cluster/saru/saru-0.0.1.ebuild
+++ b/sys-cluster/saru/saru-0.0.1.ebuild
@@ -1,88 +1,84 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/saru/saru-0.0.1.ebuild,v 1.2 2004/09/01 19:46:46 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/saru/saru-0.0.1.ebuild,v 1.3 2004/09/01 19:58:50 tantive Exp $
-DESCRIPTION="Heartbeat application to provide active active load balancers"
+inherit eutils
+DESCRIPTION="Heartbeat application to provide active active load balancers"
HOMEPAGE="http://www.ultramonkey.org/download/active_active/"
+SRC_URI="http://www.ultramonkey.org/download/active_active/${P}.tar.gz"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
DEPEND="virtual/glibc
- >=sys-cluster/ipvsadm
- >=dev-libs/popt
- >=dev-libs/glib
+ sys-cluster/ipvsadm
+ dev-libs/popt
+ dev-libs/glib
>=dev-libs/vanessa-logger-0.0.6
>=net-libs/vanessa-socket-0.0.7
>=dev-libs/vanessa-adt-0.0.6
>=dev-libs/libip_vs_user_sync-1.0.0
=sys-cluster/heartbeat-1.0.4
- >=net-firewall/iptables"
-
-SRC_URI="http://www.ultramonkey.org/download/active_active/${P}.tar.gz"
-IUSE=""
-SLOT="0"
-KEYWORDS="~x86"
-S="${WORKDIR}/${P}"
+ net-firewall/iptables"
src_compile() {
econf \
--with-iptables-lib=/lib/iptables \
--with-heartbeat-lib=/usr/lib/heartbeat \
- --with-heartbeat-fifo=/var/lib/heartbeat/api || die
-
- emake || die
+ --with-heartbeat-fifo=/var/lib/heartbeat/api || die "econf failed"
+ emake || die "emake failed"
}
src_install() {
- #einstall DESTDIR=${D} || die
+ #einstall DESTDIR=${D} || die "einstall failed"
# saru binary
- dodir /usr/sbin
exeinto /usr/sbin
- doexe saru/saru || die
+ doexe saru/saru || die "doexe failed"
dodir /usr/lib/heartbeat
- dosym /usr/sbin/saru /usr/lib/heartbeat/saru || die
+ dosym /usr/sbin/saru /usr/lib/heartbeat/saru || die "dosym failed"
# iptable module
- dodir /lib/iptables/
insinto /lib/iptables/
insopts -m0755
- doins iptables/extensions/libipt_saru.so || die
+ doins iptables/extensions/libipt_saru.so || die "doins failed"
dodir /lib/modules/${KV}/kernel/net/ipv4/netfilter
insinto /lib/modules/${KV}/kernel/net/ipv4/netfilter
- doins iptables/kernel/ipt_saru.o || die
+ doins iptables/kernel/ipt_saru.o || die "doins failed"
dodir /etc/init.d /etc/conf.d /etc/saru
insinto /etc/conf.d
- newins ${FILESDIR}/saru.conf saru || die
+ newins ${FILESDIR}/saru.conf saru || die "newins failed"
insinto /etc/saru
- doins etc/saru/saru.conf || die
+ doins etc/saru/saru.conf || die "doins failed"
exeinto /etc/init.d
- newexe ${FILESDIR}/saru.init saru || die
+ newexe ${FILESDIR}/saru.init saru || die "newexe failed"
- doman saru/saru.8 || die
+ doman saru/saru.8 || die "doman failed"
dodir /var/lib/heartbeat/api
- mknod -m 200 ${D}/var/lib/heartbeat/api/saru_1.req p || die
- fowners 65:65 /var/lib/heartbeat/api/saru_1.req || die
- mknod -m 600 ${D}/var/lib/heartbeat/api/saru_1.rsp p || die
- fowners 65:65 /var/lib/heartbeat/api/saru_1.rsp || die
-
- dodoc ChangeLog README INSTALL TODO NEWS AUTHORS || die
- dodoc patches/linux-2.4.20-outgoing_mac.hidden.patch \
- patches/linux-2.4.20-outgoing_mac.patch || die
- newdoc patches/README README.patches || die
+ mknod -m 200 ${D}/var/lib/heartbeat/api/saru_1.req p || die "mknod failed"
+ fowners 65:65 /var/lib/heartbeat/api/saru_1.req || die "fowners failed"
+ mknod -m 600 ${D}/var/lib/heartbeat/api/saru_1.rsp p || die "mknod failed"
+ fowners 65:65 /var/lib/heartbeat/api/saru_1.rsp || die "fowners failed"
+
+ dodoc ChangeLog README INSTALL TODO NEWS AUTHORS \
+ patches/linux-2.4.20-outgoing_mac.hidden.patch \
+ patches/linux-2.4.20-outgoing_mac.patch || die "dodoc failed"
+ newdoc patches/README README.patches || die "newdoc failed"
}
pkg_postinst() {
- einfo ""
+ einfo
einfo "upgrading module dependencies ... "
/sbin/depmod -a -F /lib/modules/${KV}/build/System.map
einfo "... done"
- einfo ""
+ einfo
einfo "Please remember to re-emerge saru when you upgrade your kernel!"
- einfo ""
+ einfo
}