summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-06-22 20:36:53 +0000
committerMichael Imhof <tantive@gentoo.org>2003-06-22 20:36:53 +0000
commit7f64d7985deab55cfb3a49eda4730b918d9f4450 (patch)
tree18f6d1eb9576a2471c5241f0e107ab1e1b9d4c07 /sys-cluster
parentVersion bump (diff)
downloadhistorical-7f64d7985deab55cfb3a49eda4730b918d9f4450.tar.gz
historical-7f64d7985deab55cfb3a49eda4730b918d9f4450.tar.bz2
historical-7f64d7985deab55cfb3a49eda4730b918d9f4450.zip
Version bump
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmosix-user/Manifest4
-rw-r--r--sys-cluster/openmosix-user/files/digest-openmosix-user-0.3.41
-rw-r--r--sys-cluster/openmosix-user/openmosix-user-0.3.4.ebuild93
3 files changed, 96 insertions, 2 deletions
diff --git a/sys-cluster/openmosix-user/Manifest b/sys-cluster/openmosix-user/Manifest
index c9b7de0eca47..491f3279129f 100644
--- a/sys-cluster/openmosix-user/Manifest
+++ b/sys-cluster/openmosix-user/Manifest
@@ -1,4 +1,4 @@
-MD5 1063e0aa10df3a0a4f3cb9ad5fde312a ChangeLog 2979
+MD5 1acfa4e0580b20a9c2447c9da94728f8 ChangeLog 3084
MD5 e21d23eb9248958047f0f443fe7049fd openmosix-user-0.3-r1.ebuild 2831
MD5 131c4803f4d8b9d1d7b6f30472fb3f8a openmosix-user-0.3-r2.ebuild 2434
MD5 31ab641339939de36b5bbf012e013b90 openmosix-user-0.3-r3.ebuild 2434
@@ -6,7 +6,7 @@ MD5 010bdc7b672f424e9dcce6c218591648 openmosix-user-0.3-r4.ebuild 2434
MD5 967b8f6d44babc659304d466aab9d168 openmosix-user-0.3.2.ebuild 2408
MD5 df0100b47de90d3d9273794b33c76090 openmosix-user-0.3.3.ebuild 2409
MD5 84f69caf636e94ad8e5267b67dd3d4a3 openmosix-user-0.3.ebuild 2431
-MD5 52b5f630b299572fcf5f00150599865a openmosix-user-0.3.4.ebuild 2410
+MD5 b41e538ab779ae94662619119d88c7c6 openmosix-user-0.3.4.ebuild 2410
MD5 1a83df8e8607ccf902f056b08fe43df2 files/digest-openmosix-user-0.3 68
MD5 1a83df8e8607ccf902f056b08fe43df2 files/digest-openmosix-user-0.3-r1 68
MD5 1a83df8e8607ccf902f056b08fe43df2 files/digest-openmosix-user-0.3-r2 68
diff --git a/sys-cluster/openmosix-user/files/digest-openmosix-user-0.3.4 b/sys-cluster/openmosix-user/files/digest-openmosix-user-0.3.4
new file mode 100644
index 000000000000..127c8b5cf1d9
--- /dev/null
+++ b/sys-cluster/openmosix-user/files/digest-openmosix-user-0.3.4
@@ -0,0 +1 @@
+MD5 f9c9cee038aa95004a77907b226ff006 openmosix-tools-0.3.4.tar.bz2 277601
diff --git a/sys-cluster/openmosix-user/openmosix-user-0.3.4.ebuild b/sys-cluster/openmosix-user/openmosix-user-0.3.4.ebuild
new file mode 100644
index 000000000000..6eb66c2986c2
--- /dev/null
+++ b/sys-cluster/openmosix-user/openmosix-user-0.3.4.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmosix-user/openmosix-user-0.3.4.ebuild,v 1.1 2003/06/22 20:36:29 tantive Exp $
+
+S=${WORKDIR}/openmosix-tools-${PV}
+DESCRIPTION="User-land utilities for openMosix process migration (clustering) software"
+SRC_URI="mirror://sourceforge/openmosix/openmosix-tools-${PV}.tar.bz2"
+HOMEPAGE="http://www.openmosix.com/"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-kernel/openmosix-sources-2.4.18"
+RDEPEND="${DEPEND}
+ sys-apps/findutils
+ dev-lang/perl"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 -ppc -sparc -alpha"
+
+pkg_setup() {
+ if [ -z "`readlink /usr/src/linux|grep openmosix`" ]; then
+ eerror
+ eerror "Your linux kernel sources do not appear to be openmosix,"
+ eerror "please check your /usr/src/linux symlink."
+ eerror
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cat > configuration << EOF
+
+OPENMOSIX=/usr/src/linux
+PROCDIR=/proc/hpc
+MONNAME=mmon
+CC=gcc
+INSTALLDIR=/usr
+CFLAGS=-I/m/include -I./ -I/usr/include -I\${OPENMOSIX}/include -I${S}/moslib ${CFLAGS}
+INSTALL=/usr/bin/install
+EOF
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --with-kerneldir=/usr/src/linux \
+ --mandir=${D}usr/share/man \
+ --sysconfdir=${D}/etc \
+ --bindir=${D}/bin \
+ --sbindir=${D}/sbin \
+ --libdir=${D}/usr/lib \
+ --with-sysvdir=${D}/etc/init.d \
+ --with-configdir=${D}/etc/openmosix \
+ --with-mapdir=${D}/etc \
+ --prefix=${D}/usr
+ make
+}
+
+src_install() {
+ dodir /bin
+ dodir /sbin
+ dodir /usr/share/doc
+ dodir /usr/share/man/man1
+
+ make install
+
+ dodoc COPYING README
+ rm ${D}/etc/init.d/openmosix
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/openmosix.init openmosix
+ insinto /etc
+ rm ${D}/etc/openmosix.map
+ #Test if mosix.map is present, stub appropriate openmosix.map
+ #file
+ if test -e /etc/openmosix.map; then
+ einfo "Seems you already have a openmosix.map file, using it.";
+ elif test -e /etc/mosix.map; then
+ cp /etc/mosix.map ${WORKDIR}/openmosix.map;
+ doins ${WORKDIR}/openmosix.map;
+ else
+ doins ${FILESDIR}/openmosix.map;
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo " To complete openMosix installation, edit /etc/openmosix.map or"
+ einfo " delete it to use autodiscovery."
+ einfo " Type:"
+ einfo " # rc-update add openmosix default"
+ einfo " to add openMosix to the default runlevel."
+ einfo
+}