summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-07-06 00:03:02 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-07-06 00:03:02 +0000
commit98a46883480126c82294197b8967b1a35519d100 (patch)
treeccaf2fcfc5026ae2f64221b4577346cc7f3ae6c2 /sys-cluster
parentPatch for security bug #97651 (diff)
downloadhistorical-98a46883480126c82294197b8967b1a35519d100.tar.gz
historical-98a46883480126c82294197b8967b1a35519d100.tar.bz2
historical-98a46883480126c82294197b8967b1a35519d100.zip
Clean up the ebuild usage of SMP, to allow control of shmem builds with USE=sharedmem. Move to using virtual/pbs and virtual/mpi as mpiexec works with both of them. Clean up the ebuild a bit as well.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpiexec/ChangeLog12
-rw-r--r--sys-cluster/mpiexec/files/digest-mpiexec-0.76-r21
-rw-r--r--sys-cluster/mpiexec/mpiexec-0.76-r2.ebuild49
3 files changed, 60 insertions, 2 deletions
diff --git a/sys-cluster/mpiexec/ChangeLog b/sys-cluster/mpiexec/ChangeLog
index 047f204d052c..fa895e4820bd 100644
--- a/sys-cluster/mpiexec/ChangeLog
+++ b/sys-cluster/mpiexec/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/mpiexec
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpiexec/ChangeLog,v 1.11 2004/09/19 18:55:59 tantive Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpiexec/ChangeLog,v 1.12 2005/07/06 00:03:02 robbat2 Exp $
+
+*mpiexec-0.76-r2 (06 Jul 2005)
+
+ 06 Jul 2005; Robin H. Johnson <robbat2@gentoo.org>
+ +mpiexec-0.76-r2.ebuild:
+ Clean up the ebuild usage of SMP, to allow control of shmem builds with
+ USE=sharedmem. Move to using virtual/pbs and virtual/mpi as mpiexec works
+ with both of them. Clean up the ebuild a bit as well.
19 Sep 2004; Michael Imhof <tantive@gentoo.org> -mpiexec-0.74-r1.ebuild:
Cleaned out old ebuild.
diff --git a/sys-cluster/mpiexec/files/digest-mpiexec-0.76-r2 b/sys-cluster/mpiexec/files/digest-mpiexec-0.76-r2
new file mode 100644
index 000000000000..f29c7300584d
--- /dev/null
+++ b/sys-cluster/mpiexec/files/digest-mpiexec-0.76-r2
@@ -0,0 +1 @@
+MD5 5bd0512b7e6a2f86ac0397f93e6e6966 mpiexec-0.76.tgz 145241
diff --git a/sys-cluster/mpiexec/mpiexec-0.76-r2.ebuild b/sys-cluster/mpiexec/mpiexec-0.76-r2.ebuild
new file mode 100644
index 000000000000..55420f4cca40
--- /dev/null
+++ b/sys-cluster/mpiexec/mpiexec-0.76-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpiexec/mpiexec-0.76-r2.ebuild,v 1.1 2005/07/06 00:03:02 robbat2 Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="replacement for mpirun, integrates MPI with PBS."
+SRC_URI="http://www.osc.edu/~pw/mpiexec/${P}.tgz"
+HOMEPAGE="http://www.osc.edu/~pw/mpiexec/"
+IUSE="sharedmem"
+
+DEPEND="virtual/libc
+ virtual/pbs
+ virtual/mpi"
+RDEPEND="net-misc/openssh"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+src_compile() {
+ # sharedmem should NOT be used on SMP boxes
+ myconf="`use_enable sharedmem p4-shmem`"
+
+ # mpich-p4 is the best default
+ append-ldflags -L/usr/$(get_libdir)/pbs
+ ./configure --mandir=/usr/share/man/man1/ \
+ --prefix=/usr \
+ --with-pbs=/usr \
+ --with-default-comm=mpich-p4 \
+ ${myconf} || die "configure failed"
+
+ make || die "compile failed"
+
+ ## demo-hello: usefull for debugging
+ make hello || die "compile hello failed"
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man/man1/ \
+ install || die "install failed"
+
+ ## demo-hello:
+ dodoc hello.c
+ newbin hello hello_mpiexec
+
+ dodoc LICENSE README README.lam ChangeLog
+}