summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-04-25 03:57:16 +0000
committerMike Frysinger <vapier@gentoo.org>2012-04-25 03:57:16 +0000
commitd5c377a8873996af85a3a30719c314a025acbb83 (patch)
treee518995ebe2eeeabb029422b7b0ab8b073a02bd5 /sys-devel/autoconf/autoconf-2.69.ebuild
parentVersion bump. Tentative fix for random failure which might be due to python-3... (diff)
downloadhistorical-d5c377a8873996af85a3a30719c314a025acbb83.tar.gz
historical-d5c377a8873996af85a3a30719c314a025acbb83.tar.bz2
historical-d5c377a8873996af85a3a30719c314a025acbb83.zip
Version bump.
Package-Manager: portage-2.2.0_alpha100/cvs/Linux x86_64
Diffstat (limited to 'sys-devel/autoconf/autoconf-2.69.ebuild')
-rw-r--r--sys-devel/autoconf/autoconf-2.69.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-devel/autoconf/autoconf-2.69.ebuild b/sys-devel/autoconf/autoconf-2.69.ebuild
new file mode 100644
index 000000000000..7555c0416509
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.69.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.69.ebuild,v 1.1 2012/04/25 03:57:16 vapier Exp $
+
+EAPI="3"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
+ http://git.savannah.gnu.org/r/${PN}.git"
+
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="Used to create autoconfiguration files"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+
+LICENSE="GPL-3"
+SLOT="2.5"
+IUSE="emacs"
+
+DEPEND=">=sys-apps/texinfo-4.3
+ >=sys-devel/m4-1.4.6
+ >=dev-lang/perl-5.6"
+RDEPEND="${DEPEND}
+ >=sys-devel/autoconf-wrapper-10"
+PDEPEND="emacs? ( app-emacs/autoconf-mode )"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ autoreconf -f -i || die
+ fi
+}
+
+src_configure() {
+ # Disable Emacs in the build system since it is in a separate package.
+ export EMACS=no
+ econf --program-suffix="-${PV}" || die
+ # econf updates config.{sub,guess} which forces the manpages
+ # to be regenerated which we dont want to do #146621
+ touch man/*.1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS NEWS README TODO THANKS \
+ ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+}