summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-10 03:17:05 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-10 03:17:05 +0000
commit6e01facafe8641404d43b07a318d9eec18f36578 (patch)
treec734556410ab312fa46910be894e032395a45ff7 /sys-devel/bison
parentadded ppc to keywords (diff)
downloadhistorical-6e01facafe8641404d43b07a318d9eec18f36578.tar.gz
historical-6e01facafe8641404d43b07a318d9eec18f36578.tar.bz2
historical-6e01facafe8641404d43b07a318d9eec18f36578.zip
bison upgrade, and masked
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog10
-rw-r--r--sys-devel/bison/bison-1.35.ebuild55
-rw-r--r--sys-devel/bison/files/digest-bison-1.351
3 files changed, 65 insertions, 1 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 05f98b98a244..c209a2fa72d2 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/bison
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.2 2002/04/02 16:16:30 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.3 2002/08/10 03:17:05 seemant Exp $
+
+*bison-1.35 (09 Aug 2002)
+
+ 09 Aug 2002; Seemant Kulleen <seemant@gentoo.org> bison-1.35.ebuild
+ files/digest-bison-1.35 :
+
+ Version bump to newest stable, which fixes issues with the spanish
+ language environment.
*bison-1.34-r1 (2 Apr 2002)
diff --git a/sys-devel/bison/bison-1.35.ebuild b/sys-devel/bison/bison-1.35.ebuild
new file mode 100644
index 000000000000..6ad68acd3364
--- /dev/null
+++ b/sys-devel/bison/bison-1.35.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.35.ebuild,v 1.1 2002/08/10 03:17:05 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A yacc-compatible parser generator"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/bison/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --prefix=/usr \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ if [ -z "`use static`" ]
+ then
+ emake ${MAKEOPTS} || die
+ else
+ emake ${MAKEOPTS} LDFLAGS=-static || die
+ fi
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ datadir=/usr/share \
+ mandir=/usr/share/man \
+ infodir=/usr/share/info \
+ install || die
+
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING AUTHORS NEWS ChangeLog README REFERENCES OChangeLog
+ docinto txt
+ dodoc doc/FAQ
+ else
+ rm -rf ${D}/usr/share/man ${D}/usr/share/info
+ fi
+}
+
diff --git a/sys-devel/bison/files/digest-bison-1.35 b/sys-devel/bison/files/digest-bison-1.35
new file mode 100644
index 000000000000..a6f3dce646a1
--- /dev/null
+++ b/sys-devel/bison/files/digest-bison-1.35
@@ -0,0 +1 @@
+MD5 e2c06b27f463c6ba19cafbe113d53b1e bison-1.35.tar.gz 770444