summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-10-06 22:18:48 +0000
committerTravis Tilley <lv@gentoo.org>2004-10-06 22:18:48 +0000
commit6582fbc846b7ea37c6198967d7916ffac15fbab3 (patch)
treee8f10b7b976e59379a72d2079aac2cb4ca52f46a /sys-devel/gcc/gcc-3.2.3-r4.ebuild
parentmanifest (diff)
downloadhistorical-6582fbc846b7ea37c6198967d7916ffac15fbab3.tar.gz
historical-6582fbc846b7ea37c6198967d7916ffac15fbab3.tar.bz2
historical-6582fbc846b7ea37c6198967d7916ffac15fbab3.zip
fix those annoying QA messages about awk
Diffstat (limited to 'sys-devel/gcc/gcc-3.2.3-r4.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.2.3-r4.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-devel/gcc/gcc-3.2.3-r4.ebuild b/sys-devel/gcc/gcc-3.2.3-r4.ebuild
index 39ee9c143d6c..3d1837d6a7ff 100644
--- a/sys-devel/gcc/gcc-3.2.3-r4.ebuild
+++ b/sys-devel/gcc/gcc-3.2.3-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.3-r4.ebuild,v 1.10 2004/08/25 13:55:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.3-r4.ebuild,v 1.11 2004/10/06 22:18:48 lv Exp $
-inherit eutils flag-o-matic libtool
+inherit eutils flag-o-matic libtool versionator
# Recently there has been a lot of stability problem in Gentoo-land. Many
# things can be the cause to this, but I believe that it is due to gcc3
@@ -36,8 +36,10 @@ do_filter_flags() {
[ ! -n "${CCHOST}" ] && export CCHOST="${CHOST}"
LOC="/usr"
-MY_PV="`echo ${PV} | awk -F. '{ gsub(/_pre.*|_alpha.*/, ""); print $1 "." $2 }'`"
-MY_PV_FULL="`echo ${PV} | awk '{ gsub(/_pre.*|_alpha.*/, ""); print $0 }'`"
+#MY_PV="`echo ${PV} | awk -F. '{ gsub(/_pre.*|_alpha.*/, ""); print $1 "." $2 }'`"
+#MY_PV_FULL="`echo ${PV} | awk '{ gsub(/_pre.*|_alpha.*/, ""); print $0 }'`"
+MY_PV="$(get_version_component_range 1-2)"
+MY_PV_FULL="$(get_version_component_range 1-3)"
LIBPATH="${LOC}/lib/gcc-lib/${CCHOST}/${MY_PV_FULL}"
BINPATH="${LOC}/${CCHOST}/gcc-bin/${MY_PV}"