summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-05 20:37:40 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-05 20:37:40 +0000
commite5bef2a03edea7e82bb305a0f6987464411ae4b2 (patch)
tree27c98b19347ed7f59cf7566804146d4bbba73135 /sys-devel/gcc/gcc-3.2.3-r4.ebuild
parentfix revert SLOT behavior (diff)
downloadhistorical-e5bef2a03edea7e82bb305a0f6987464411ae4b2.tar.gz
historical-e5bef2a03edea7e82bb305a0f6987464411ae4b2.tar.bz2
historical-e5bef2a03edea7e82bb305a0f6987464411ae4b2.zip
change SLOT to be the same for all ebuilds now
Diffstat (limited to 'sys-devel/gcc/gcc-3.2.3-r4.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.2.3-r4.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/sys-devel/gcc/gcc-3.2.3-r4.ebuild b/sys-devel/gcc/gcc-3.2.3-r4.ebuild
index 3d1837d6a7ff..03e9d4176bec 100644
--- a/sys-devel/gcc/gcc-3.2.3-r4.ebuild
+++ b/sys-devel/gcc/gcc-3.2.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.3-r4.ebuild,v 1.11 2004/10/06 22:18:48 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.3-r4.ebuild,v 1.12 2004/12/05 20:37:40 vapier Exp $
inherit eutils flag-o-matic libtool versionator
@@ -105,12 +105,7 @@ IUSE="static nls bootstrap java build"
# are not cross compiling, than we want SLOT to only contain
# $PV, as people upgrading to new gcc layout will not have
# their old gcc unmerged ...
-if [ "${CHOST}" == "${CCHOST}" ]
-then
- SLOT="${MY_PV}"
-else
- SLOT="${CCHOST}-${MY_PV}"
-fi
+SLOT="${CTARGET:-${CHOST}}-${MY_PV}"
DEPEND=">=sys-libs/glibc-2.3.2-r3
mips? ( >=sys-devel/binutils-2.13.90.0.16 )