summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-30 02:48:38 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-30 02:48:38 +0000
commit3d1259c603ec583a72aefefcc9f669a35d2e61c9 (patch)
tree711d48f1d98b081a9bd8c7ce6a6ec959c308860a /sys-devel/gcc/gcc-4.0.3.ebuild
parentarm/s390/sh love (diff)
downloadhistorical-3d1259c603ec583a72aefefcc9f669a35d2e61c9.tar.gz
historical-3d1259c603ec583a72aefefcc9f669a35d2e61c9.tar.bz2
historical-3d1259c603ec583a72aefefcc9f669a35d2e61c9.zip
Move glibc into PDEPEND and drop libstdc++ garbage.
Package-Manager: portage-2.1.1_pre1-r5
Diffstat (limited to 'sys-devel/gcc/gcc-4.0.3.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.0.3.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/sys-devel/gcc/gcc-4.0.3.ebuild b/sys-devel/gcc/gcc-4.0.3.ebuild
index 5bf4b5c985eb..01426e9bcdcc 100644
--- a/sys-devel/gcc/gcc-4.0.3.ebuild
+++ b/sys-devel/gcc/gcc-4.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.3.ebuild,v 1.8 2006/06/22 05:38:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.3.ebuild,v 1.9 2006/06/30 02:48:38 vapier Exp $
PATCH_VER="1.3"
UCLIBC_VER="1.0"
@@ -42,17 +42,15 @@ RDEPEND=">=sys-libs/zlib-1.1.4
>=sys-libs/ncurses-5.2-r2
nls? ( sys-devel/gettext )
)"
-if [[ ${CATEGORY} != cross-* ]] ; then
- RDEPEND="${RDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
-fi
DEPEND="${RDEPEND}
test? ( sys-devel/autogen )
>=sys-apps/texinfo-4.2-r4
>=sys-devel/bison-1.875
>=${CATEGORY}/binutils-2.15.94"
-
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
- x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( =virtual/libstdc++-3.3 ) ) ) )"
+PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
+fi
src_unpack() {
gcc_src_unpack