summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-17 06:02:55 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-17 06:02:55 +0000
commit6178b8fba86c0f9db8ae4d5b3db94c262d66e059 (patch)
treeb62bda3a1137dba3631fbd9b8146fb163ba7ea63 /sys-devel/kgcc64
parentfinish up support for TOOLCHAIN_ALLOWED_LANGS to allow kgcc64 to work properly (diff)
downloadhistorical-6178b8fba86c0f9db8ae4d5b3db94c262d66e059.tar.gz
historical-6178b8fba86c0f9db8ae4d5b3db94c262d66e059.tar.bz2
historical-6178b8fba86c0f9db8ae4d5b3db94c262d66e059.zip
old
Diffstat (limited to 'sys-devel/kgcc64')
-rw-r--r--sys-devel/kgcc64/files/digest-kgcc64-3.4.56
-rw-r--r--sys-devel/kgcc64/kgcc64-3.4.5.ebuild58
2 files changed, 0 insertions, 64 deletions
diff --git a/sys-devel/kgcc64/files/digest-kgcc64-3.4.5 b/sys-devel/kgcc64/files/digest-kgcc64-3.4.5
deleted file mode 100644
index e8fa30125de1..000000000000
--- a/sys-devel/kgcc64/files/digest-kgcc64-3.4.5
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 c4147ee1bff0babe6e0ed4033da04677 gcc-3.4.5-patches-1.0.tar.bz2 47040
-RMD160 9279bd4c5fe17efbb97079448b1d83930081e6a6 gcc-3.4.5-patches-1.0.tar.bz2 47040
-SHA256 3a84d2cc9a6e7b6c1424ad2d1943952b30069e4d4893626930242c9014180bad gcc-3.4.5-patches-1.0.tar.bz2 47040
-MD5 7c3c3c3e764dcee5eb771432062d69e1 gcc-3.4.5.tar.bz2 28254232
-RMD160 611ad033a76ada49d43529fc694142e856a039fa gcc-3.4.5.tar.bz2 28254232
-SHA256 be5738a94076052453894dd7d35b1efbb017bba1da0b28495d145f98fe018a09 gcc-3.4.5.tar.bz2 28254232
diff --git a/sys-devel/kgcc64/kgcc64-3.4.5.ebuild b/sys-devel/kgcc64/kgcc64-3.4.5.ebuild
deleted file mode 100644
index 91be1ae0e9e6..000000000000
--- a/sys-devel/kgcc64/kgcc64-3.4.5.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-3.4.5.ebuild,v 1.2 2006/03/01 01:10:28 vapier Exp $
-
-case ${CHOST} in
- hppa*) CTARGET=hppa64-${CHOST#*-};;
- mips*) CTARGET=${CHOST/mips/mips64};;
- powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
- s390*) CTARGET=${CHOST/s390/s390x};;
- sparc*) CTARGET=${CHOST/sparc/sparc64};;
- i?86*) CTARGET=x86_64-${CHOST#*-};;
-esac
-export CTARGET
-export USE="nocxx nossp nopie -fortran -gcj -objc -multilib"
-
-PATCH_VER="1.0"
-ETYPE="gcc-compiler"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
-
-inherit toolchain eutils
-
-DESCRIPTION="64bit kernel compiler"
-
-KEYWORDS="-* ~hppa ~mips ~ppc ~s390 ~sparc ~x86"
-
-# unlike every other target, hppa has not unified the 32/64 bit
-# ports in binutils yet
-DEPEND="hppa? ( sys-devel/binutils-hppa64 )"
-
-src_unpack() {
- gcc_src_unpack
-
- epatch "${GCC_FILESDIR}"/3.4.4/gcc-3.4.4-cross-compile.patch
-
- # Arch stuff
- case $(tc-arch) in
- mips)
- # Patch forward-ported from a gcc-3.0.x patch that adds -march=r10000 and
- # -mtune=r10000 support to gcc (Allows the compiler to generate code to
- # take advantage of R10k's second ALU, perform shifts, etc..
- #
- # Needs re-porting to DFA in gcc-4.0 - Any Volunteers? :)
- epatch "${GCC_FILESDIR}"/3.4.2/gcc-3.4.x-mips-add-march-r10k.patch
-
- # This is a very special patch -- it allows us to build semi-usable kernels
- # on SGI IP28 (Indigo2 Impact R10000) systems. The patch is henceforth
- # regarded as a kludge by upstream, and thus, it will never get accepted upstream,
- # but for our purposes of building a kernel, it works.
- # Unless you're building an IP28 kernel, you really don't need care about what
- # this patch does, because if you are, you are probably already aware of what
- # it does.
- # All that said, the abilities of this patch are disabled by default and need
- # to be enabled by passing -mip28-cache-barrier. Only used to build kernels,
- # There is the possibility it may be used for very specific userland apps too.
- epatch "${GCC_FILESDIR}"/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v2.patch
- ;;
- esac
-}