summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-14 13:24:33 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-14 13:24:33 +0000
commitf8dc42f4cb131f82a54b6110b59bf02231de541d (patch)
treeb2884089901ac196581ff9928f00ea09e5f271b4 /sys-devel/libtool
parentupdated comment about libtool 1.4.2 (diff)
downloadhistorical-f8dc42f4cb131f82a54b6110b59bf02231de541d.tar.gz
historical-f8dc42f4cb131f82a54b6110b59bf02231de541d.tar.bz2
historical-f8dc42f4cb131f82a54b6110b59bf02231de541d.zip
adding 1.4.1-r1 which has the applied patch
Diffstat (limited to 'sys-devel/libtool')
-rw-r--r--sys-devel/libtool/files/1.4/libtool-1.4.ltmain.sh-hack.diff (renamed from sys-devel/libtool/files/1.4/libtool-1.4.2.ltmain.sh-hack.diff)0
-rw-r--r--sys-devel/libtool/files/digest-libtool-1.4.1-r11
-rw-r--r--sys-devel/libtool/libtool-1.4.1-r1.ebuild35
-rw-r--r--sys-devel/libtool/libtool-1.4.2.ebuild4
4 files changed, 38 insertions, 2 deletions
diff --git a/sys-devel/libtool/files/1.4/libtool-1.4.2.ltmain.sh-hack.diff b/sys-devel/libtool/files/1.4/libtool-1.4.ltmain.sh-hack.diff
index 6fa99486a3f5..6fa99486a3f5 100644
--- a/sys-devel/libtool/files/1.4/libtool-1.4.2.ltmain.sh-hack.diff
+++ b/sys-devel/libtool/files/1.4/libtool-1.4.ltmain.sh-hack.diff
diff --git a/sys-devel/libtool/files/digest-libtool-1.4.1-r1 b/sys-devel/libtool/files/digest-libtool-1.4.1-r1
new file mode 100644
index 000000000000..2dbd61720e62
--- /dev/null
+++ b/sys-devel/libtool/files/digest-libtool-1.4.1-r1
@@ -0,0 +1 @@
+MD5 28582af0b96513f223e970db1a9a5cde libtool-1.4.1.tar.gz 1130496
diff --git a/sys-devel/libtool/libtool-1.4.1-r1.ebuild b/sys-devel/libtool/libtool-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..ec2197340bbe
--- /dev/null
+++ b/sys-devel/libtool/libtool-1.4.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.4.1-r1.ebuild,v 1.1 2002/01/14 13:24:33 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A shared library tool for developers"
+SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/libtool/libtool.html"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info
+ assert
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog* NEWS \
+ README THANKS TODO doc/PLATFORMS
+
+ cd ${D}/usr/share/libtool
+ patch -p0 < ${FILESDIR}/1.4/${PN}-1.4.ltmain.sh-hack.diff
+
+}
+
+
+
+
diff --git a/sys-devel/libtool/libtool-1.4.2.ebuild b/sys-devel/libtool/libtool-1.4.2.ebuild
index d16298e1c6b6..7801ad8659a4 100644
--- a/sys-devel/libtool/libtool-1.4.2.ebuild
+++ b/sys-devel/libtool/libtool-1.4.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.4.2.ebuild,v 1.2 2002/01/14 11:41:32 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.4.2.ebuild,v 1.3 2002/01/14 13:24:33 hallski Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A shared library tool for developers"
@@ -26,5 +26,5 @@ src_install() {
README THANKS TODO doc/PLATFORMS
cd ${D}/usr/share/libtool
- patch -p0 < ${FILESDIR}/1.4/${PN}-${PV}.ltmain.sh-hack.diff
+ patch -p0 < ${FILESDIR}/1.4/${PN}-1.4.ltmain.sh-hack.diff
}