summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-31 17:50:17 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-31 17:50:17 +0000
commitbb6148c75457de713561164c810cceab51fbba39 (patch)
treeaccb107efde48703cc01d02cde0fa4b3b9712fe1 /sys-devel/m4/m4-1.4.15.ebuild
parentVersion bump. Tests run fine on ruby18 and ree18 without the gentoo patch now. (diff)
downloadhistorical-bb6148c75457de713561164c810cceab51fbba39.tar.gz
historical-bb6148c75457de713561164c810cceab51fbba39.tar.bz2
historical-bb6148c75457de713561164c810cceab51fbba39.zip
Version bump.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sys-devel/m4/m4-1.4.15.ebuild')
-rw-r--r--sys-devel/m4/m4-1.4.15.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-devel/m4/m4-1.4.15.ebuild b/sys-devel/m4/m4-1.4.15.ebuild
new file mode 100644
index 000000000000..0cfa0ddd4755
--- /dev/null
+++ b/sys-devel/m4/m4-1.4.15.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4.15.ebuild,v 1.1 2010/08/31 17:50:17 vapier Exp $
+
+EAPI="3"
+
+DESCRIPTION="GNU macro processor"
+HOMEPAGE="http://www.gnu.org/software/m4/m4.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="examples"
+
+# remember: cannot dep on autoconf since it needs us
+DEPEND="app-arch/xz-utils"
+RDEPEND=""
+
+src_configure() {
+ # Disable automagic dependency over libsigsegv; see bug #278026
+ export ac_cv_libsigsegv=no
+
+ local myconf=""
+ [[ ${USERLAND} != "GNU" ]] && myconf="--program-prefix=g"
+ econf --enable-changeword ${myconf}
+}
+
+src_test() {
+ [[ -d /none ]] && die "m4 tests will fail with /none/" #244396
+ emake check || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc BACKLOG ChangeLog NEWS README* THANKS TODO
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ rm -f "${D}"/usr/share/doc/${PF}/examples/Makefile*
+ fi
+ rm -f "${D}"/usr/lib/charset.alias #172864
+}