summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-08-04 02:10:10 +0000
committerPeter Gavin <pete@gentoo.org>2001-08-04 02:10:10 +0000
commit6fd0bd6576f4e2351570f35da83e18cc1f81520b (patch)
tree60de80454dda811a1a4c7696276da5460164cd00 /sys-devel/spython
parentfixed info warning (/usr/share/info/dir entry). (diff)
downloadhistorical-6fd0bd6576f4e2351570f35da83e18cc1f81520b.tar.gz
historical-6fd0bd6576f4e2351570f35da83e18cc1f81520b.tar.bz2
historical-6fd0bd6576f4e2351570f35da83e18cc1f81520b.zip
updated portage and added spython-2.0-r7
Diffstat (limited to 'sys-devel/spython')
-rw-r--r--sys-devel/spython/spython-2.0-r7.ebuild91
1 files changed, 91 insertions, 0 deletions
diff --git a/sys-devel/spython/spython-2.0-r7.ebuild b/sys-devel/spython/spython-2.0-r7.ebuild
new file mode 100644
index 000000000000..90f574a4ab5b
--- /dev/null
+++ b/sys-devel/spython/spython-2.0-r7.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r7.ebuild,v 1.1 2001/08/04 02:10:10 pete Exp $
+
+S=${WORKDIR}/Python-2.0
+S2=${WORKDIR}/python-fchksum-1.1
+DESCRIPTION="A really great language -- minimalist python environment"
+SRC_URI="http://www.python.org/ftp/python/src/BeOpen-Python-2.0.tar.bz2
+ http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
+
+HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
+
+DEPEND=">=sys-devel/autoconf-2.13
+ >=sys-libs/zlib-1.1.3
+ readline? ( >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2 )"
+
+RDEPEND="virtual/glibc"
+PROVIDE="virtual/python"
+
+src_unpack() {
+
+ unpack BeOpen-Python-2.0.tar.bz2
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+ autoconf
+
+ cd ${S}/Modules
+
+ cp -a ${FILESDIR}/pfconfig.h .
+ unpack python-fchksum-1.1.tar.gz
+
+ echo '*static*' >> Setup.local
+
+ echo "zlib zlibmodule.c -lz" >> Setup.local
+ if [ "`use readline`" ]
+ then
+ echo "readline readline.c -lreadline -lncurses" >> Setup.local
+ fi
+
+ echo "fchksum fchksum.c md5_2.c" >> Setup.local
+
+ cd python-fchksum-1.1
+ cp -a md5.h ../md5_2.h
+ sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
+ sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
+
+}
+
+src_compile() {
+
+ export LDFLAGS=-static
+
+ try ./configure --prefix=/usr --without-libdb
+
+ #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
+ #included with python is for db 1.85 only.
+
+ cp Makefile Makefile.orig
+ sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
+ cd ${S}/Modules
+ cp Makefile.pre Makefile.orig
+ sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
+ Makefile.orig > Makefile.pre
+
+ # Parallel make does not work
+ cd ${S}
+ try make
+
+}
+
+src_install() {
+
+ dodir /usr/share/man
+ try make install prefix=${D}/usr MANDIR=${D}/usr/share/man
+
+ rm -rf ${D}/usr/include
+ rm -rf ${D}/usr/lib/${PN}${PV}/config
+
+ dodir /usr/lib/python${PV}/site-packages
+ rm -rf ${D}/usr/lib/spython${PV}/site-packages
+ dosym ../python${PV}/site-packages /usr/lib/spython${PV}/site-packages
+
+ if [ "`use build`" ] || [ "`use bootcd`" ]
+ then
+ rm -rf ${D}/usr/share/man
+ rm -rf ${D}/usr/lib/python${PV}/{test,config}
+ rm -rf ${D}/usr/include
+ fi
+}