summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-02-01 09:44:37 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-02-01 09:44:37 +0000
commit0464981d43cc0332c831cddc27850a91dd024906 (patch)
tree30557ff60668aef9324df324914948aaca804d26 /sys-devel
parentAdded dosym /usr/lib/libbsd-compat.a /usr/lib/libbsd.a. (diff)
downloadhistorical-0464981d43cc0332c831cddc27850a91dd024906.tar.gz
historical-0464981d43cc0332c831cddc27850a91dd024906.tar.bz2
historical-0464981d43cc0332c831cddc27850a91dd024906.zip
hopefully fixed the perl test failing issue, but I can't check locally
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/perl/perl-5.6.1-r2.ebuild78
1 files changed, 40 insertions, 38 deletions
diff --git a/sys-devel/perl/perl-5.6.1-r2.ebuild b/sys-devel/perl/perl-5.6.1-r2.ebuild
index c11b796cb68c..5808ce95fd3d 100644
--- a/sys-devel/perl/perl-5.6.1-r2.ebuild
+++ b/sys-devel/perl/perl-5.6.1-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.1-r2.ebuild,v 1.2 2002/01/31 23:19:27 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.1-r2.ebuild,v 1.3 2002/02/01 09:44:37 gbevin Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
@@ -14,6 +14,32 @@ RDEPEND="virtual/glibc berkdb? ( >=sys-libs/db-3.2.3h-r3 =sys-libs/db-1.85-r1 )
src_compile() {
+ # configure for libperl.so
+ sh Configure -des \
+ -Darchname=${CHOST%%-*}-linux \
+ -Dcccdlflags='-fPIC' \
+ -Dccdlflags='-rdynamic' \
+ -Dprefix=/usr \
+ -Doptimize="${CFLAGS}" \
+ -Duselargefiles \
+ -Duseshrplib \
+ -Dlibperl=libperl.so \
+ -Dd_dosuid \
+ -Dd_semctl_semun \
+ ${myconf} || die
+ # create libperl.so and move it out of the way
+ mv -f Makefile Makefile_orig
+ sed -e 's#^CCDLFLAGS = -rdynamic -Wl,-rpath,/usr/lib/perl5/.*#CCDLFLAGS = -rdynamic#' \
+ Makefile_orig > Makefile
+ export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
+ make libperl.so || die
+ mv libperl.so ${WORKDIR}
+
+ cd ${WORKDIR}
+ rm -rf ${S}
+ unpack ${A}
+ cd ${S}
+ # configure for libperl.a
# this is gross -- from Christian Gafton, Red Hat
cat > config.over <<EOF
installprefix=${D}/usr
@@ -46,50 +72,26 @@ EOF
else
myconf="${myconf} -Ui_db -Ui_ndbm"
fi
+ sh Configure -des -Dprefix=/usr -Dd_dosuid -Dd_semctl_semun ${myconf} -Duselargefiles -Darchname=${CHOST%%-*}-linux
- # configure for libperl.so
- sh Configure -des \
- -Darchname=${CHOST%%-*}-linux \
- -Dcccdlflags='-fPIC' \
- -Dccdlflags='-rdynamic' \
- -Dprefix=/usr \
- -Doptimize="${CFLAGS}" \
- -Duselargefiles \
- -Duseshrplib \
- -Dlibperl=libperl.so \
- -Dd_dosuid \
- -Dd_semctl_semun \
- ${myconf} || die
- mv -f Makefile Makefile_orig
- sed -e 's#^CCDLFLAGS = -rdynamic -Wl,-rpath,/usr/lib/perl5/.*#CCDLFLAGS = -rdynamic#' \
- Makefile_orig > Makefile
+ #Optimize ;)
+ cp config.sh config.sh.orig
+ sed -e "s/optimize='-O2'/optimize=\'${CFLAGS}\'/" config.sh.orig > config.sh
+ #THIS IS USED LATER:
export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
- make libperl.so || die
- mv libperl.so ${WORKDIR}
- # configure for libperl.a
- make distclean
- sh Configure -des \
- -Darchname=${CHOST%%-*}-linux \
- -Dcccdlflags='-fPIC' \
- -Dccdlflags='-rdynamic' \
- -Dprefix=/usr \
- -Doptimize="${CFLAGS}" \
- -Duselargefiles \
- -Dd_dosuid \
- -Dd_semctl_semun \
- ${myconf} || die
- mv -f Makefile Makefile_orig
- sed -e 's#^CCDLFLAGS = -rdynamic -Wl,-rpath,/usr/lib/perl5/.*#CCDLFLAGS = -rdynamic#' \
- Makefile_orig > Makefile
- export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
+# Umm, for some reason this doesn't want to work, so we'll just remove
+# the makefiles and let make rebuild them itself. (It seems to do it
+# right the second time... -- pete
+# cp makefile makefile.orig
+# sed -e "s:^0::" makefile.orig > makefile
+
#for some reason, this rm -f doesn't seem to actually do anything. So we explicitly use "Makefile"
#(rather than the default "makefile") in all make commands below.
rm -f makefile x2p/makefile
make -f Makefile || die
-
- # || die on make test is failing.
- make -f Makefile test
+ # Parallel make fails
+ make -f Makefile test
}
src_install() {