summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-12 13:48:37 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-12 13:48:37 +0000
commit05a804115f2a5f20d5f71b14f70f80777d722afa (patch)
tree5d46b07c6260182978d9003e7f143cb70998eb87 /sys-devel
parentadded USE dependent nls compilation (diff)
downloadhistorical-05a804115f2a5f20d5f71b14f70f80777d722afa.tar.gz
historical-05a804115f2a5f20d5f71b14f70f80777d722afa.tar.bz2
historical-05a804115f2a5f20d5f71b14f70f80777d722afa.zip
Added USE dependent nls compilation
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/ChangeLog8
-rw-r--r--sys-devel/binutils/binutils-2.11.92.0.12.3-r2.ebuild114
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.11.92.0.12.3-r22
3 files changed, 123 insertions, 1 deletions
diff --git a/sys-devel/binutils/ChangeLog b/sys-devel/binutils/ChangeLog
index 7998154bf2ff..e37358e784fb 100644
--- a/sys-devel/binutils/ChangeLog
+++ b/sys-devel/binutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/binutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.1 2002/02/01 21:53:38 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.2 2002/03/12 13:48:37 seemant Exp $
+
+*binutils-2.11.92.0.12.3-r2 (12 Mar 2002)
+
+ 12 Mar 2002; Seemant Kulleen <seemant@gentoo.org> ChangeLog :
+
+ Updated copyright year, and added USE dependent nls compilation.
*binutils-2.11.92.0.12.3-r1 (1 Feb 2002)
diff --git a/sys-devel/binutils/binutils-2.11.92.0.12.3-r2.ebuild b/sys-devel/binutils/binutils-2.11.92.0.12.3-r2.ebuild
new file mode 100644
index 000000000000..b264faea9b51
--- /dev/null
+++ b/sys-devel/binutils/binutils-2.11.92.0.12.3-r2.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.11.92.0.12.3-r2.ebuild,v 1.1 2002/03/12 13:48:37 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools necessary to build programs"
+SRC_URI="http://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/${PN}-manpages-${PV}.tar.bz2"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd ${S}
+ #man pages are tarred up seperately because building them depends on perl, which isn't installed at
+ #Gentoo Linux bootstrap time.
+ mkdir man; cd man
+ tar xjf ${DISTDIR}/${PN}-manpages-${PV}.tar.bz2 || die
+}
+
+src_compile() {
+
+ local myconf
+
+ use nls && \
+ myconf="${myconf} --without-included-gettext" || \
+ myconf="${myconf} --disable-nls"
+
+ ./configure --enable-shared \
+ --enable-64-bit-bfd \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ if [ "`use static`" ]
+ then
+ emake -e LDFLAGS=-all-static || die
+ else
+ emake || die
+ fi
+
+ if [ -z "`use build`" ]
+ then
+ #make the info pages (makeinfo included with gcc is used)
+ make info || die
+ fi
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ #c++filt is included with gcc -- what are these GNU people thinking?
+ #but not the manpage, so leave that!
+ rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
+
+ #strip has a symlink going from /usr/${CHOST}/bin/strip to /usr/bin/strip
+ #we should reverse it:
+
+ rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
+ #the strip symlink gets created in the loop below
+
+ #ar, as, ld, nm, ranlib and strip are in two places; create symlinks. This will reduce the
+ #size of the tbz2 significantly. We also move all the stuff in /usr/bin to /usr/${CHOST}/bin
+ #and create the appropriate symlinks. Things are cleaner that way.
+ cd ${D}/usr/bin
+ local x
+ for x in * strip
+ do
+ if [ ! -e ../${CHOST}/bin/${x} ]
+ then
+ mv $x ../${CHOST}/bin/${x}
+ else
+ rm -f $x
+ fi
+ ln -s ../${CHOST}/bin/${x} ${x}
+ done
+
+ cd ${S}
+ if [ -z "`use build`" ]
+ then
+ #install info pages
+ make infodir=${D}/usr/share/info \
+ install-info || die
+ dodoc COPYING* README
+ docinto bfd
+ dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
+ docinto binutils
+ dodoc binutils/ChangeLog binutils/NEWS binutils/README
+ docinto gas
+ dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
+ docinto gprof
+ dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
+ docinto ld
+ dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
+ docinto libiberty
+ dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
+ docinto opcodes
+ dodoc opcodes/ChangeLog*
+ #install pre-generated manpages
+ rm -f ${D}/usr/share/man/man1/*
+ doman ${S}/man/*.1
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+}
+
+
+
diff --git a/sys-devel/binutils/files/digest-binutils-2.11.92.0.12.3-r2 b/sys-devel/binutils/files/digest-binutils-2.11.92.0.12.3-r2
new file mode 100644
index 000000000000..cda554e3e27f
--- /dev/null
+++ b/sys-devel/binutils/files/digest-binutils-2.11.92.0.12.3-r2
@@ -0,0 +1,2 @@
+MD5 14e7d6e283326662d7287d8cba47cc58 binutils-2.11.92.0.12.3.tar.bz2 8099613
+MD5 eb31a229238366e29387fe8332816ccf binutils-manpages-2.11.92.0.12.3.tar.bz2 52062