summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-19 15:15:03 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-19 15:15:03 +0000
commit0e44c6c1a3332608ce961d43a6186901b776bbcd (patch)
tree70402578c5b2be78f2748020ff66a0abffdc83cb /sys-devel
parentsecurity fix, bug 12190 (diff)
downloadhistorical-0e44c6c1a3332608ce961d43a6186901b776bbcd.tar.gz
historical-0e44c6c1a3332608ce961d43a6186901b776bbcd.tar.bz2
historical-0e44c6c1a3332608ce961d43a6186901b776bbcd.zip
rip out ICC support
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bison/ChangeLog6
-rw-r--r--sys-devel/bison/bison-1.35.ebuild13
-rw-r--r--sys-devel/bison/bison-1.75.ebuild10
3 files changed, 17 insertions, 12 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 6ec7c117df5f..4cfd66514fc9 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/bison
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.10 2002/12/13 11:00:39 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.11 2002/12/19 15:15:03 azarah Exp $
+
+ 19 Dec 2002; Martin Schlemmer <azarah@gentoo.org> bison-1.35.ebuild :
+
+ Ripp out the icc stuff, as it cause problem, bug #12357.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/sys-devel/bison/bison-1.35.ebuild b/sys-devel/bison/bison-1.35.ebuild
index f0554fd94c05..a1c14943136c 100644
--- a/sys-devel/bison/bison-1.35.ebuild
+++ b/sys-devel/bison/bison-1.35.ebuild
@@ -1,19 +1,20 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.35.ebuild,v 1.8 2002/12/10 01:18:55 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.35.ebuild,v 1.9 2002/12/19 15:15:03 azarah Exp $
-IUSE="nls static build icc"
+IUSE="nls static build" # icc"
-S=${WORKDIR}/${P}
+S="${WORKDIR}/${P}"
DESCRIPTION="A yacc-compatible parser generator"
SRC_URI="ftp://ftp.gnu.org/pub/gnu/bison/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
-DEPEND="nls? ( sys-devel/gettext )
- icc? ( dev-lang/icc )"
+DEPEND="nls? ( sys-devel/gettext )"
+# icc? ( dev-lang/icc )"
src_compile() {
@@ -22,7 +23,7 @@ src_compile() {
then
myconf="--disable-nls"
fi
- use icc && CC="iccbin" CXX="iccbin" LD="iccbin"
+# use icc && CC="iccbin" CXX="iccbin" LD="iccbin"
./configure --prefix=/usr \
--datadir=/usr/share \
diff --git a/sys-devel/bison/bison-1.75.ebuild b/sys-devel/bison/bison-1.75.ebuild
index 0177718389ff..dcef365200f5 100644
--- a/sys-devel/bison/bison-1.75.ebuild
+++ b/sys-devel/bison/bison-1.75.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.75.ebuild,v 1.5 2002/12/10 01:18:55 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.75.ebuild,v 1.6 2002/12/19 15:15:03 azarah Exp $
-IUSE="nls static build icc"
+IUSE="nls static build" # icc"
S="${WORKDIR}/${P}"
DESCRIPTION="A yacc-compatible parser generator"
@@ -14,12 +14,12 @@ SLOT="0"
# do not compile xfree
KEYWORDS="~x86"
-DEPEND="nls? ( sys-devel/gettext )
- icc? ( dev-lang/icc )"
+DEPEND="nls? ( sys-devel/gettext )"
+# icc? ( dev-lang/icc )"
src_compile() {
- use icc && CC="iccbin" CXX="iccbin" LD="iccbin"
+# use icc && CC="iccbin" CXX="iccbin" LD="iccbin"
local myconf=""
use nls || myconf="--disable-nls"