summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-08-31 19:20:26 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-08-31 19:20:26 +0000
commit0f67a54becd2c3431ad6fa490a07e1ce16defa13 (patch)
treee0ee2c9816eb7b1658fa35f9b7c4e4f2a181129c /sys-devel
parentdigests (diff)
downloadhistorical-0f67a54becd2c3431ad6fa490a07e1ce16defa13.tar.gz
historical-0f67a54becd2c3431ad6fa490a07e1ce16defa13.tar.bz2
historical-0f67a54becd2c3431ad6fa490a07e1ce16defa13.zip
potential fix for gettext problem. Testing now.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-2.95.3-r4.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sys-devel/gcc/gcc-2.95.3-r4.ebuild b/sys-devel/gcc/gcc-2.95.3-r4.ebuild
index 6ad6fd329613..903e4e4a0c8a 100644
--- a/sys-devel/gcc/gcc-2.95.3-r4.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3-r4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
# Author: Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r4.ebuild,v 1.7 2001/08/31 03:11:59 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r4.ebuild,v 1.8 2001/08/31 19:20:26 drobbins Exp $
SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${P}/${P}.tar.gz
ftp://ftp.freesoftware.com/pub/sourceware/gcc/infrastructure/libg++-2.8.1.3.tar.gz
@@ -54,10 +54,10 @@ src_compile() {
then
myconf="${myconf} --with-included-gettext --enable-nls"
else
- myconf="${myconf} --enable-nls"
+ myconf="${myconf} --without-included-gettext --enable-nls"
fi
else
- myconf="${myconf} --disable-nls"
+ myconf="${myconf} --with-included-gettext --disable-nls"
fi
# gcc does not like optimization
@@ -66,9 +66,8 @@ src_compile() {
export CXXFLAGS="${CXXFLAGS/-O?/}"
${S}/configure --prefix=${LOC} --mandir=${LOC}/share/man --infodir=${LOC}/share/info \
- --enable-version-specific-runtime-libs \
- --host=${CHOST} --build=${CHOST} --target=${CHOST} --enable-threads \
- --with-local-prefix=${LOC}/local ${myconf} --without-included-gettext || die
+ --enable-version-specific-runtime-libs --host=${CHOST} --build=${CHOST} --target=${CHOST} --enable-threads \
+ --with-local-prefix=${LOC}/local ${myconf} || die
if [ -z "`use static`" ]
then