summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-22 23:56:18 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-22 23:56:18 +0000
commit1386e1769f6fa20a83014ac978e354259d6fddc7 (patch)
tree018da5b9bf56556392beb221604343ddb265821d /sys-devel
parentMark alpha/arm/ia64/s390/sh stable #336381. (diff)
downloadhistorical-1386e1769f6fa20a83014ac978e354259d6fddc7.tar.gz
historical-1386e1769f6fa20a83014ac978e354259d6fddc7.tar.bz2
historical-1386e1769f6fa20a83014ac978e354259d6fddc7.zip
Version bump.
Package-Manager: portage-2.2_rc85/cvs/Linux x86_64
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/ChangeLog8
-rw-r--r--sys-devel/autoconf/autoconf-2.68.ebuild51
-rw-r--r--sys-devel/autoconf/autoconf-9999.ebuild4
3 files changed, 60 insertions, 3 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index ee5e0b10aedc..10be61b49d09 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/autoconf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.154 2010/09/22 23:55:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.155 2010/09/22 23:56:18 vapier Exp $
+
+*autoconf-2.68 (22 Sep 2010)
+
+ 22 Sep 2010; Mike Frysinger <vapier@gentoo.org> +autoconf-2.68.ebuild,
+ autoconf-9999.ebuild:
+ Version bump.
22 Sep 2010; Mike Frysinger <vapier@gentoo.org> autoconf-2.65-r1.ebuild:
Mark alpha/arm/ia64/s390/sh stable #336381.
diff --git a/sys-devel/autoconf/autoconf-2.68.ebuild b/sys-devel/autoconf/autoconf-2.68.ebuild
new file mode 100644
index 000000000000..7ef6f7e2c891
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.68.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.68.ebuild,v 1.1 2010/09/22 23:56:18 vapier Exp $
+
+EAPI="2"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.gnu.org/autoconf.git"
+ inherit git
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+ #KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="Used to create autoconfiguration files"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+
+LICENSE="GPL-3"
+SLOT="2.5"
+IUSE="emacs"
+
+DEPEND=">=sys-apps/texinfo-4.3
+ >=sys-devel/m4-1.4.6
+ dev-lang/perl"
+RDEPEND="${DEPEND}
+ >=sys-devel/autoconf-wrapper-10"
+PDEPEND="emacs? ( app-emacs/autoconf-mode )"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ autoreconf -f -i || die
+ fi
+}
+
+src_configure() {
+ # Disable Emacs in the build system since it is in a separate package.
+ export EMACS=no
+ econf --program-suffix="-${PV}" || die
+ # econf updates config.{sub,guess} which forces the manpages
+ # to be regenerated which we dont want to do #146621
+ touch man/*.1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS NEWS README TODO THANKS \
+ ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+}
diff --git a/sys-devel/autoconf/autoconf-9999.ebuild b/sys-devel/autoconf/autoconf-9999.ebuild
index 7094a701e6a6..d46cfb78976e 100644
--- a/sys-devel/autoconf/autoconf-9999.ebuild
+++ b/sys-devel/autoconf/autoconf-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-9999.ebuild,v 1.2 2010/09/19 22:28:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-9999.ebuild,v 1.3 2010/09/22 23:56:18 vapier Exp $
EAPI="2"
@@ -26,7 +26,7 @@ DEPEND=">=sys-apps/texinfo-4.3
>=sys-devel/m4-1.4.6
dev-lang/perl"
RDEPEND="${DEPEND}
- >=sys-devel/autoconf-wrapper-9-r1"
+ >=sys-devel/autoconf-wrapper-10"
PDEPEND="emacs? ( app-emacs/autoconf-mode )"
src_prepare() {