summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-07 04:27:26 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-07 04:27:26 +0000
commit6203119aa95217a27f306079af0ee346e869d865 (patch)
tree6a95f8b8bd652a2c729092e177be68433748ad40 /sys-devel
parentneed mirror://gentoo for older files #67498 (diff)
downloadhistorical-6203119aa95217a27f306079af0ee346e869d865.tar.gz
historical-6203119aa95217a27f306079af0ee346e869d865.tar.bz2
historical-6203119aa95217a27f306079af0ee346e869d865.zip
fix outdated head/tail format #65668
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/Manifest8
-rw-r--r--sys-devel/gcc/gcc-2.95.3-r8.ebuild10
2 files changed, 11 insertions, 7 deletions
diff --git a/sys-devel/gcc/Manifest b/sys-devel/gcc/Manifest
index a5210d60cc74..8b686cfd389a 100644
--- a/sys-devel/gcc/Manifest
+++ b/sys-devel/gcc/Manifest
@@ -2,7 +2,7 @@
Hash: SHA1
MD5 5371f9df6e973106e58e4cbc03959161 ChangeLog 75661
-MD5 40f450ed72bcc7f9118f2672005c614b gcc-2.95.3-r8.ebuild 8337
+MD5 174a113e9053c5b695257f31f08ce64c gcc-2.95.3-r8.ebuild 8432
MD5 f804f416c7c486569541c7cc81b07cbb gcc-3.2.3-r4.ebuild 19729
MD5 32f6bf1128374ba782984fa69f87d0ea gcc-3.3.2-r2.ebuild 17859
MD5 1a33850ffcbfdcd016e44ba0ed751242 gcc-3.3.2-r5.ebuild 21183
@@ -113,7 +113,7 @@ MD5 4edccdf0b4f6dbbc9f7bc9370c255e0c files/3.4.0/gcc34-reiser4-fix.patch 587
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.10 (GNU/Linux)
-iD8DBQFBtS32roRuSHgZdywRAop8AJwKPPt8/ewuk4ODcaDBaPylOoyiygCgh1iq
-nJd7P3uTcpjzjqjgBwexwiE=
-=4A3c
+iD8DBQFBtTE3roRuSHgZdywRAhjIAJ95xVGQRCSRBAj4cXUkbaQ9cojm5QCgiDGk
+rRRxjkUnSYg+ePi9v2xIFZA=
+=y/hM
-----END PGP SIGNATURE-----
diff --git a/sys-devel/gcc/gcc-2.95.3-r8.ebuild b/sys-devel/gcc/gcc-2.95.3-r8.ebuild
index b08bf2c14671..cd0013415b4b 100644
--- a/sys-devel/gcc/gcc-2.95.3-r8.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3-r8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r8.ebuild,v 1.35 2004/12/07 00:14:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r8.ebuild,v 1.36 2004/12/07 04:27:26 vapier Exp $
-inherit eutils flag-o-matic gcc versionator
+inherit eutils flag-o-matic gcc versionator fixheadtails
# The next command strips most flags from CFLAGS/CXXFLAGS. If you do
# not like it, comment it out, but do not file bugreports if you run into
@@ -92,11 +92,15 @@ src_unpack() {
epatch ${FILESDIR}/2.95.3/${P}-alpha.diff
fi
+ cd ${S}
+
+ # Fix outdated head/tails format #65668
+ ht_fix_file configure gcc/Makefile.in
+
# Currently if any path is changed via the configure script, it breaks
# installing into ${D}. We should not patch it in src_install() with
# absolute paths, as some modules then gets rebuild with the wrong
# paths. Thus we use $FAKE_ROOT.
- cd ${S}
for x in $(find . -name Makefile.in)
do
# Fix --datadir=