summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-08-14 15:42:37 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-08-14 15:42:37 +0000
commit6e01dd2bb14b3a8c84637e3d27bcd7d98fd09077 (patch)
treeefa5cb4b2285e98e861fafaeae5730c6474bf6e0 /sys-devel
parenttrailing space, manifest rebuild (diff)
downloadhistorical-6e01dd2bb14b3a8c84637e3d27bcd7d98fd09077.tar.gz
historical-6e01dd2bb14b3a8c84637e3d27bcd7d98fd09077.tar.bz2
historical-6e01dd2bb14b3a8c84637e3d27bcd7d98fd09077.zip
The rest of the patch for bug 58931
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libperl/ChangeLog5
-rw-r--r--sys-devel/libperl/Manifest10
-rw-r--r--sys-devel/libperl/libperl-5.8.7.ebuild10
3 files changed, 14 insertions, 11 deletions
diff --git a/sys-devel/libperl/ChangeLog b/sys-devel/libperl/ChangeLog
index 271a6e562098..a9e3924b6318 100644
--- a/sys-devel/libperl/ChangeLog
+++ b/sys-devel/libperl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/libperl
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.78 2005/08/14 15:37:34 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.79 2005/08/14 15:42:37 mcummings Exp $
+
+ 14 Aug 2005; Michael Cummings <mcummings@gentoo.org> libperl-5.8.7.ebuild:
+ The rest of the patch for bug 58931
14 Aug 2005; Michael Cummings <mcummings@gentoo.org> libperl-5.8.7.ebuild:
Bug #58931, more userland darwin
diff --git a/sys-devel/libperl/Manifest b/sys-devel/libperl/Manifest
index 933f4babdec8..73d98f6c1734 100644
--- a/sys-devel/libperl/Manifest
+++ b/sys-devel/libperl/Manifest
@@ -1,8 +1,8 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 1c0f363da1567bb144ce06af5cd3f923 libperl-5.8.7.ebuild 10927
-MD5 71f619a7e2dfcfffd7790ed16f20fafe ChangeLog 12039
+MD5 ce6c15a55ad9d39caa3a46ac0ea9ff57 libperl-5.8.7.ebuild 10928
+MD5 79d28acc84fc5e84f8b2c19f26ab1864 ChangeLog 12155
MD5 faa9f545e3711c37ee78d83eb338eebb libperl-5.8.6.ebuild 10471
MD5 0875c75155583aa2bec241b36265d371 libperl-5.8.5-r1.ebuild 10029
MD5 bf70b069d8a29b1cba1949437f7e8b0c libperl-5.8.5.ebuild 9920
@@ -21,7 +21,7 @@ MD5 0a07934d74ccb1133cf0f3650cb94efc files/digest-libperl-5.8.6-r1 64
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFC/2WUtG5z4I8BtQoRAoeDAJ4r7TBeCNcag/kZejeBbSoqRvLUcQCeJ2AN
-hInlT6QFUyKOaAXnfrDGRA0=
-=3iKT
+iD8DBQFC/2aDtG5z4I8BtQoRArhHAJ0TzDFYBvAPgFv8Zwx5ITzaj7dyVQCfRGBf
+jCduOHl03aUCr3lfAP3dzoo=
+=cc65
-----END PGP SIGNATURE-----
diff --git a/sys-devel/libperl/libperl-5.8.7.ebuild b/sys-devel/libperl/libperl-5.8.7.ebuild
index 65ac65763093..9eb1d01a394a 100644
--- a/sys-devel/libperl/libperl-5.8.7.ebuild
+++ b/sys-devel/libperl/libperl-5.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.7.ebuild,v 1.9 2005/08/14 15:38:08 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.7.ebuild,v 1.10 2005/08/14 15:42:37 mcummings Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -332,12 +332,12 @@ pkg_postinst() {
# Next bit is to try and setup the /usr/lib/libperl.so symlink
# properly ...
- local libnumber="`ls -1 ${ROOT}usr/$(get_libdir)/libperl$(get_libname).?.* | grep -v '\.old' | wc -l`"
+ local libnumber="`ls -1 ${ROOT}usr/$(get_libdir)/libperl$(get_libname ?.*) | grep -v '\.old' | wc -l`"
if [ "${libnumber}" -eq 1 ]
then
# Only this version of libperl is installed, so just link libperl.so
# to the *soname* version of it ...
- ln -snf libperl$(get_libname).${PERLSLOT} ${ROOT}usr/$(get_libdir)/libperl$(get_libname)
+ ln -snf libperl$(get_libname ${PERLSLOT}) ${ROOT}usr/$(get_libdir)/libperl$(get_libname)
else
if [ -x "${ROOT}/usr/bin/perl" ]
then
@@ -348,13 +348,13 @@ pkg_postinst() {
cd ${ROOT}usr/$(get_libdir)
# Link libperl.so to the *soname* versioned lib ...
- ln -snf `echo libperl$(get_libname).?.${perlversion} | cut -d. -f1,2,3` libperl$(get_libname)
+ ln -snf `echo libperl$(get_libname ?.${perlversion}) | cut -d. -f1,2,3` libperl$(get_libname)
else
local x latest
# Nope, we are not so lucky ... try to figure out what version
# is the latest, and keep fingers crossed ...
- for x in `ls -1 ${ROOT}usr/$(get_libdir)/libperl$(get_libname).?.*`
+ for x in `ls -1 ${ROOT}usr/$(get_libdir)/libperl$(get_libname ?.*)`
do
latest="${x}"
done