summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2005-01-16 22:54:17 +0000
committerJohn Mylchreest <johnm@gentoo.org>2005-01-16 22:54:17 +0000
commitcb08fe7879576b7f46d137702a04c5d23427f24c (patch)
treed29481391cc1c91dcc99ade42ab4728f7857e536 /sys-fs/fuse
parentnew upstream version. fixes bug #55177. (diff)
downloadhistorical-cb08fe7879576b7f46d137702a04c5d23427f24c.tar.gz
historical-cb08fe7879576b7f46d137702a04c5d23427f24c.tar.bz2
historical-cb08fe7879576b7f46d137702a04c5d23427f24c.zip
fuse-2.2_pre3 converted to use linux-mod with its new fancy CHECK_CONFIG options. 1.4 still needs converting.
Package-Manager: portage-2.0.51-r13
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/Manifest12
-rw-r--r--sys-fs/fuse/fuse-2.2_pre3.ebuild49
2 files changed, 25 insertions, 36 deletions
diff --git a/sys-fs/fuse/Manifest b/sys-fs/fuse/Manifest
index 091c6d97ba26..acd6a026b760 100644
--- a/sys-fs/fuse/Manifest
+++ b/sys-fs/fuse/Manifest
@@ -1,10 +1,20 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 d9443f8a72726d8e779c1a9064122fa7 fuse-1.4.ebuild 1555
MD5 61f3c8ddc1e887be58825483427d13ff fuse-2.1.ebuild 1250
MD5 b356b597461b75a9bf7b555c46f3863e ChangeLog 1813
MD5 6e89ba8198764bfd079a0cfa18dca593 metadata.xml 264
-MD5 43ecf3436a60528ada68a114daf74975 fuse-2.2_pre3.ebuild 1671
+MD5 cf4db735cee0982360608e90a3faa392 fuse-2.2_pre3.ebuild 1470
MD5 a24d5bc33d0d36527f183fce45e5c78e files/fuse-1.4-kernel-2.6.10.patch 1052
MD5 86c18e0aa1b9961decf250349afc0fdc files/digest-fuse-1.4 60
MD5 fd5c3c8819559265b221879ca45deae3 files/digest-fuse-2.1 60
MD5 c1ef6366ba5892111ddef08887328663 files/fuse-fix-lazy-binding.patch 398
MD5 1a9d13833510849d37a9ab5a7e34b83c files/digest-fuse-2.2_pre3 65
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFB6vChm/TpOlox+n8RAtiLAJwImxvEBVD1DlZXhHLbHdvmSzQV5wCg+UCH
+rEJaC5AexgEgUTDEy7JzmDw=
+=9ldF
+-----END PGP SIGNATURE-----
diff --git a/sys-fs/fuse/fuse-2.2_pre3.ebuild b/sys-fs/fuse/fuse-2.2_pre3.ebuild
index 5ece387ef360..dd7a98c0d0e6 100644
--- a/sys-fs/fuse/fuse-2.2_pre3.ebuild
+++ b/sys-fs/fuse/fuse-2.2_pre3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.2_pre3.ebuild,v 1.1 2005/01/15 19:32:24 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.2_pre3.ebuild,v 1.2 2005/01/16 22:54:17 johnm Exp $
inherit linux-mod eutils
@@ -12,23 +12,15 @@ LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc"
IUSE=""
S=${WORKDIR}/${MY_P}
+
+CONFIG_CHECK="@FUSE_FS:fuse"
MODULE_NAMES="fuse(fs:${S}/kernel)"
BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
- fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
+ fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
BUILD_TARGETS="all"
-
-pkg_setup() {
- linux-mod_pkg_setup
-
- if linux_chkconfig_present FUSE_FS
- then
- einfo "Not compiling the kernel module as it is already in the kernel"
- FUSEMOD=""
- else
- einfo "Compiling the kernel module as it is not yet in the kernel"
- FUSEMOD="true"
- fi
-}
+ECONF_PARAMS="--with-kernel=${KV_DIR}"
+FUSE_FS_ERROR="We have detected FUSE already built into the kernel. \
+ We will continue, but we wont build the module this time."
src_unpack() {
unpack ${A}
@@ -37,17 +29,14 @@ src_unpack() {
}
src_compile() {
- econf --disable-kernel-module --disable-example || die "econf failed"
+ einfo "Preparing fuse userland"
+ econf --disable-kernel-module --disable-example || \
+ die "econf failed for fuse userland"
emake || die "emake failed"
- if [ -n "${FUSEMOD}" ]
- then
- cd kernel
- econf --with-kernel="${ROOT}${KV_DIR}" || die "econf kernel failed"
- sed -i 's/.*depmod.*//' Makefile
- convert_to_m Makefile
- linux-mod_src_compile
- fi
+ sed -i 's/.*depmod.*//g' ${S}/kernel/Makefile.in
+ convert_to_m ${S}/kernel/Makefile.in
+ linux-mod_src_compile
}
src_install() {
@@ -58,15 +47,5 @@ src_install() {
docinto example
dodoc example/*
- if [ -n "${FUSEMOD}" ]
- then
- linux-mod_src_install
- fi
-}
-
-pkg_postinst() {
- if [ -n "${FUSEMOD}" ]
- then
- linux-mod_pkg_postinst
- fi
+ linux-mod_src_install
}