summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-01-05 09:57:51 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-01-05 09:57:51 +0000
commit9d32d861d5c4a106954ee1a0c11776fc39e13751 (patch)
tree28d9de31e507215b3f7eaf34d5e4a6175689f54c /sys-fs/safecopy/safecopy-1.6.ebuild
parentx86 stable per bug 350417 (diff)
downloadhistorical-9d32d861d5c4a106954ee1a0c11776fc39e13751.tar.gz
historical-9d32d861d5c4a106954ee1a0c11776fc39e13751.tar.bz2
historical-9d32d861d5c4a106954ee1a0c11776fc39e13751.zip
Version bump. Drop old. Fixes bug 338068.
Package-Manager: portage-2.2.0_alpha12/cvs/Linux x86_64
Diffstat (limited to 'sys-fs/safecopy/safecopy-1.6.ebuild')
-rw-r--r--sys-fs/safecopy/safecopy-1.6.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-fs/safecopy/safecopy-1.6.ebuild b/sys-fs/safecopy/safecopy-1.6.ebuild
new file mode 100644
index 000000000000..6759a05c4e90
--- /dev/null
+++ b/sys-fs/safecopy/safecopy-1.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/safecopy/safecopy-1.6.ebuild,v 1.1 2011/01/05 09:57:51 scarabeus Exp $
+
+EAPI=3
+
+inherit base
+
+DESCRIPTION="Data recovery tool to fault-tolerantly extract data from damaged (io-errors) devices or files."
+HOMEPAGE="http://safecopy.sourceforge.net"
+SRC_URI="mirror://sourceforge/safecopy/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ sed -e 's:bin/sh:bin/bash:' \
+ -i "${S}"/test/test.sh || die "sed failed"
+}
+
+src_configure() {
+ base_src_configure
+ if use test; then
+ cd "${S}"/simulator
+ econf
+ fi
+}
+
+src_compile() {
+ base_src_compile
+ if use test; then
+ cd "${S}"/simulator
+ emake || die "Simulator compilation failed -- needed for testing"
+ fi
+}
+
+src_install() {
+ base_src_install
+ dodoc README || die "copying documentation failed"
+}
+
+src_test() {
+ cd "${S}"/test
+ ./test.sh || die "./tesh.sh failed"
+}