summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2012-04-02 00:35:01 +0000
committerMike Pagano <mpagano@gentoo.org>2012-04-02 00:35:01 +0000
commitf6bc544d66cf5e70a0822f285f301eaca287cfa3 (patch)
tree538c68d6cade4adaed3315fc61fa39b0bbd928fc /sys-kernel/git-sources
parentBug #410489: missing pkgconfig dep. (diff)
downloadhistorical-f6bc544d66cf5e70a0822f285f301eaca287cfa3.tar.gz
historical-f6bc544d66cf5e70a0822f285f301eaca287cfa3.tar.bz2
historical-f6bc544d66cf5e70a0822f285f301eaca287cfa3.zip
Version bump
Package-Manager: portage-2.1.10.49/cvs/Linux i686
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/ChangeLog7
-rw-r--r--sys-kernel/git-sources/git-sources-3.4_rc1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-kernel/git-sources/ChangeLog b/sys-kernel/git-sources/ChangeLog
index df3a51825979..fd3b689c69ca 100644
--- a/sys-kernel/git-sources/ChangeLog
+++ b/sys-kernel/git-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/git-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.1290 2012/03/17 00:15:24 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.1291 2012/04/02 00:35:01 mpagano Exp $
+
+*git-sources-3.4_rc1 (02 Apr 2012)
+
+ 02 Apr 2012; Michael Pagano <mpagano@gentoo.org> +git-sources-3.4_rc1.ebuild:
+ Version bump
17 Mar 2012; Michael Pagano <mpagano@gentoo.org> git-sources-3.3_rc7.ebuild:
Fix git to retreive source tarball from mirrors instead of downloading source
diff --git a/sys-kernel/git-sources/git-sources-3.4_rc1.ebuild b/sys-kernel/git-sources/git-sources-3.4_rc1.ebuild
new file mode 100644
index 000000000000..838a9b42d1d2
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-3.4_rc1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/git-sources-3.4_rc1.ebuild,v 1.1 2012/04/02 00:35:01 mpagano Exp $
+
+EAPI="4"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE=0
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="http://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at http://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+pkg_postinst() {
+ postinst_sources
+}