summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-06-02 12:48:30 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-06-02 12:48:30 +0000
commit5ae7367551d28a896a7080369fe23cde7fd8ef45 (patch)
tree3882d3a51edf92576d5167af6bce2f32c8e6b98e /sys-kernel/ia64-sources/ia64-sources-2.4.24-r4.ebuild
parentFix use invocation (diff)
downloadhistorical-5ae7367551d28a896a7080369fe23cde7fd8ef45.tar.gz
historical-5ae7367551d28a896a7080369fe23cde7fd8ef45.tar.bz2
historical-5ae7367551d28a896a7080369fe23cde7fd8ef45.zip
Added patches for the CAN-2004-0075, CAN-2004-0181, CAN-2004-0394, and CAN-2004-0427 vulnerabilities. Bug #47881.
Diffstat (limited to 'sys-kernel/ia64-sources/ia64-sources-2.4.24-r4.ebuild')
-rw-r--r--sys-kernel/ia64-sources/ia64-sources-2.4.24-r4.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sys-kernel/ia64-sources/ia64-sources-2.4.24-r4.ebuild b/sys-kernel/ia64-sources/ia64-sources-2.4.24-r4.ebuild
new file mode 100644
index 000000000000..a6830b2fb9f8
--- /dev/null
+++ b/sys-kernel/ia64-sources/ia64-sources-2.4.24-r4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ia64-sources/ia64-sources-2.4.24-r4.ebuild,v 1.1 2004/06/02 12:48:30 plasmaroo Exp $
+
+IUSE=""
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel eutils
+OKV="`echo ${PV}|sed -e 's:^\([0-9]\+\.[0-9]\+\.[0-9]\+\).*:\1:'`"
+EXTRAVERSION="-${PN/-*/}"
+[ ! "${PR}" == "r0" ] && EXTRAVERSION="${EXTRAVERSION}-${PR}"
+KV="${OKV}${EXTRAVERSION}"
+
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/gentoo-sources-${PV}/patches.txt.gz
+
+#MYCSET="1.1063.2.37-to-1.1088"
+MYSNAPSHOT="040109"
+DESCRIPTION="Full sources for the Gentoo Kernel."
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+mirror://kernel/linux/kernel/ports/ia64/v2.4/linux-${OKV}-ia64-${MYSNAPSHOT}.diff.bz2"
+
+HOMEPAGE="http://www.gentoo.org/ http://www.kernel.org/"
+LICENSE="GPL-2"
+KEYWORDS="-* ~ia64"
+SLOT="${KV}"
+
+src_unpack() {
+
+ unpack linux-${OKV}.tar.bz2
+ cd ${WORKDIR}
+ mv linux-${OKV} linux-${KV} || die "Error moving kernel source tree to linux-${KV}"
+ cd ${WORKDIR}/linux-${KV}
+# [ ! -e ${DISTDIR}/cset-${MYCSET}.txt.gz ] && die "patch file not found"
+# cat ${DISTDIR}/cset-${MYCSET}.txt.gz | gzip -d | patch -f -p1
+ [ ! -e ${DISTDIR}/linux-${OKV}-ia64-${MYSNAPSHOT}.diff.bz2 ] && die "patch not found"
+ cat ${DISTDIR}/linux-${OKV}-ia64-${MYSNAPSHOT}.diff.bz2 | bzip2 -d | patch -f -p1
+
+ # 2.4.24 includes the do_brk, mremap and rtc fixes, so those
+ # patches aren't needed (29 Jan 2004 agriffis)
+
+ epatch ${FILESDIR}/${P}.munmap.patch || die "Failed to apply munmap patch!"
+ epatch ${FILESDIR}/${P}.CAN-2004-0010.patch || die "Failed to add the CAN-2004-0010 patch!"
+ epatch ${FILESDIR}/${P}.CAN-2004-0075.patch || die "Failed to add the CAN-2004-0075 patch!"
+ epatch ${FILESDIR}/${P}.CAN-2004-0109.patch || die "Failed to add the CAN-2004-0109 patch!"
+ epatch ${FILESDIR}/${P}.CAN-2004-0177.patch || die "Failed to add the CAN-2004-0177 patch!"
+ epatch ${FILESDIR}/${P}.CAN-2004-0178.patch || die "Failed to add the CAN-2004-0178 patch!"
+ epatch ${FILESDIR}/${P}.CAN-2004-0181.patch || die "Failed to add the CAN-2004-0181 patch!"
+ epatch ${FILESDIR}/${P}.CAN-2004-0394.patch || die "Failed to add the CAN-2004-0394 patch!"
+ epatch ${FILESDIR}/${P}.CAN-2004-0427.patch || die "Failed to add the CAN-2004-0427 patch!"
+ kernel_universal_unpack
+}
+
+pkg_postinst() {
+ kernel_pkg_postinst
+}