summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-03-21 06:25:59 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-03-21 06:25:59 +0000
commit512458648b5ba96ac7ba1975731650757131950e (patch)
treeaee6858fc7f51fa5fe9ba5f3596f6012432e73e5 /sys-kernel/linux-headers/linux-headers-2.4.23.ebuild
parentstop using deprecated ?: use syntax (diff)
downloadhistorical-512458648b5ba96ac7ba1975731650757131950e.tar.gz
historical-512458648b5ba96ac7ba1975731650757131950e.tar.bz2
historical-512458648b5ba96ac7ba1975731650757131950e.zip
Bumped 2.4.21-r1 to x86 stable, and tweaked the way headers on sparc are handled (see Changelog for more)
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-2.4.23.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.23.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.23.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.23.ebuild
index 262519096d81..88bed01f6238 100644
--- a/sys-kernel/linux-headers/linux-headers-2.4.23.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.4.23.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.23.ebuild,v 1.8 2004/03/09 00:10:11 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.23.ebuild,v 1.9 2004/03/21 06:25:59 kumba Exp $
ETYPE="headers"
inherit kernel
@@ -73,7 +73,7 @@ src_install() {
kernel_src_install
# If this is sparc, then we need to place asm_offsets.h in the proper location(s)
- if [ -n "`use sparc`" ]; then
+ if [ "${PROFILE_ARCH}" = "sparc64" ]; then
# We don't need /usr/include/asm, generate-asm-sparc will take care of this
rm -Rf ${D}/usr/include/asm
@@ -81,15 +81,11 @@ src_install() {
# We do need empty directories, though...
dodir /usr/include/asm
dodir /usr/include/asm-sparc
+ dodir /usr/include/asm-sparc64
- # Copy asm-sparc
+ # Copy asm-sparc and asm-sparc64
cp -ax ${S}/include/asm-sparc/* ${D}/usr/include/asm-sparc
-
- # If this is sparc64, then we need asm-sparc64 stuff too
- if [ "${PROFILE_ARCH}" = "sparc64" ]; then
- dodir /usr/include/asm-sparc64
- cp -ax ${S}/include/asm-sparc64/* ${D}/usr/include/asm-sparc64
- fi
+ cp -ax ${S}/include/asm-sparc64/* ${D}/usr/include/asm-sparc64
# Check if generate-asm-sparc exists
if [ -a "${FILESDIR}/generate-asm-sparc" ]; then