summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-01-24 08:05:09 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-01-24 08:05:09 +0000
commit9f0986f861a68d4b8860473edfeb00a6656dd7f8 (patch)
tree57eb2b60772652d28b8815d57ae4dd5afebd78a8 /sys-kernel/linux-sources
parentnew up-to-date XFS utils (diff)
downloadhistorical-9f0986f861a68d4b8860473edfeb00a6656dd7f8.tar.gz
historical-9f0986f861a68d4b8860473edfeb00a6656dd7f8.tar.bz2
historical-9f0986f861a68d4b8860473edfeb00a6656dd7f8.zip
XFS update (sync with tools via RDEPEND)
Diffstat (limited to 'sys-kernel/linux-sources')
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.17-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.17-r1.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.17-r1.ebuild
index e5ca0242a75b..bbaf0bae6219 100644
--- a/sys-kernel/linux-sources/linux-sources-2.4.17-r1.ebuild
+++ b/sys-kernel/linux-sources/linux-sources-2.4.17-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.17-r1.ebuild,v 1.1 2002/01/24 06:14:03 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.17-r1.ebuild,v 1.2 2002/01/24 08:05:09 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
@@ -18,12 +18,14 @@ SRC_URI="http://www.de.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 ht
PROVIDE="virtual/kernel"
HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+XFSV=20020124
+
if [ $PN = "linux-sources" ] && [ -z "`use build`" ]
then
#console-tools is needed to solve the loadkeys fiasco.
#binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
DEPEND=">=sys-devel/binutils-2.11.90.0.31 sys-apps/console-tools >=sys-apps/modutils-2.4.2 sys-devel/perl"
- RDEPEND=">=sys-libs/ncurses-5.2"
+ RDEPEND=">=sys-libs/ncurses-5.2 >=sys-apps/xfsprogs-${XFSV} >=sys-apps/dmapi-${XFSV} >=sys-apps/attr-${XFSV} >=sys-apps/acl-${XFSV} >=sys-apps/xfsdump-${XFSV}"
fi
[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"