summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStratos Psomadakis <psomas@gentoo.org>2011-08-17 15:25:25 +0000
committerStratos Psomadakis <psomas@gentoo.org>2011-08-17 15:25:25 +0000
commit58e5da90c9f49c9b3ecff27e5c9b51ee8ada2f36 (patch)
tree3b7b56754bc126fbfd1eaa02bd501bde09cdcc2e /sys-kernel/mm-sources/mm-sources-3.0.ebuild
parentNew package and ebuild for the real-time kernel patchset (diff)
downloadhistorical-58e5da90c9f49c9b3ecff27e5c9b51ee8ada2f36.tar.gz
historical-58e5da90c9f49c9b3ecff27e5c9b51ee8ada2f36.tar.bz2
historical-58e5da90c9f49c9b3ecff27e5c9b51ee8ada2f36.zip
Version bump, and remove old ebuild
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'sys-kernel/mm-sources/mm-sources-3.0.ebuild')
-rw-r--r--sys-kernel/mm-sources/mm-sources-3.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-kernel/mm-sources/mm-sources-3.0.ebuild b/sys-kernel/mm-sources/mm-sources-3.0.ebuild
new file mode 100644
index 000000000000..a7fc98f0f433
--- /dev/null
+++ b/sys-kernel/mm-sources/mm-sources-3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mm-sources/mm-sources-3.0.ebuild,v 1.1 2011/08/17 15:25:25 psomas Exp $
+
+EAPI=4
+
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE=0
+
+ETYPE="sources"
+
+inherit kernel-2 eutils
+detect_version
+
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Andrew Morton's -mmotm quilt patchset"
+HOMEPAGE="http://userweb.kernel.org/~akpm/mmotm/"
+
+PATCHSET_URI="http://userweb.kernel.org/~akpm/mmotm/broken-out.tar.gz ->
+broken-out-${PV}.tar.gz"
+SRC_URI="${KERNEL_URI} ${PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/quilt"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "Do *not* open bugs at Gentoo bugzilla, unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_unpack() {
+ kernel-2_src_unpack
+ unpack broken-out-${PV}.tar.gz
+}
+
+src_prepare() {
+ einfo "Moving -mmotm quilt patchset to patches/"
+ mv broken-out patches || die "Unable to move -mmotm patchset to patches/"
+
+ einfo "Pushing -mmotm quilt patchset."
+ quilt push -aq --leave-rejects || die "Unable to apply -mmotm quilt patchset. See the *.rej files in ${S} for more infomation."
+}