summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Eichert <viz@gentoo.org>2003-01-06 04:20:16 +0000
committerTobias Eichert <viz@gentoo.org>2003-01-06 04:20:16 +0000
commitbf89125d42b1b95c97f49a1eff5a7650217a35ff (patch)
tree76fd0ec54d7fd6244c40079a72c7ff8207b82adb /sys-kernel/xfs-sources
parentClose bug #10339. (diff)
downloadhistorical-bf89125d42b1b95c97f49a1eff5a7650217a35ff.tar.gz
historical-bf89125d42b1b95c97f49a1eff5a7650217a35ff.tar.bz2
historical-bf89125d42b1b95c97f49a1eff5a7650217a35ff.zip
version bump.
Diffstat (limited to 'sys-kernel/xfs-sources')
-rw-r--r--sys-kernel/xfs-sources/ChangeLog27
-rw-r--r--sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre32
-rw-r--r--sys-kernel/xfs-sources/xfs-sources-2.4.20_pre3.ebuild51
3 files changed, 79 insertions, 1 deletions
diff --git a/sys-kernel/xfs-sources/ChangeLog b/sys-kernel/xfs-sources/ChangeLog
index a0fb064bfeb2..1adceec1986f 100644
--- a/sys-kernel/xfs-sources/ChangeLog
+++ b/sys-kernel/xfs-sources/ChangeLog
@@ -1,6 +1,31 @@
# ChangeLog for sys-kernel/xfs-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.11 2002/12/24 02:13:30 viz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.12 2003/01/06 04:20:16 viz Exp $
+
+*xfs-sources-2.4.20_pre3 (6 Jan 2003)
+
+ 6 Jan 2003; Tobias Eichert <viz@gentoo.org> xfs-sources-2.4.20_pre3.ebuild:
+
+ New Version.
+
+ Thanks to sethbc <sethbc@gentoo.org> who helped me getting along with
+ a cryptoloop issue. If Loop IV hack is enabled it causes
+ the compilation to break with an error; changing that to a #warning
+ will fix it. More information on that in the docs file.
+
+ New from xfs-sources-2.4.20_pre2:
+
+ - Add supermount support
+ - Add usbdnet support
+ - Add futexes support
+ - Add i2c support (recent patch for lm-sensors)
+ - Add KT400 AGP / pci.ids support (should close bug #12600)
+ - Add ECC support
+ - Add v4l2 (Video for Linux 2) support
+ - Add SuperFreeS/WAN Support
+
+ Enjoy and test :)
+
*xfs-sources-2.4.29_pre2 (24 Dec 2002)
diff --git a/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre3 b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre3
new file mode 100644
index 000000000000..4b8d0d44c0b8
--- /dev/null
+++ b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre3
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 c7491db80ee8c923cf38e9c1e0c8e4a1 patches-2.4.20-xfs_pre3.tar.bz2 2299879
diff --git a/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre3.ebuild b/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre3.ebuild
new file mode 100644
index 000000000000..eb841cb24fb7
--- /dev/null
+++ b/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre3.ebuild,v 1.1 2003/01/06 04:20:16 viz Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+# This kernel also has support for the local USE flag acpi4linux which
+# activates the latest code from acpi.sourceforge.net instead of the
+# very out of date vanilla version
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV=2.4.20
+EXTRAVERSION=-xfs_pre3
+KV=${OKV}${EXTRAVERSION}
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/xfs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the XFS Specialized Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.databoogie.net/kernel/patches-${KV}.tar.bz2"
+KEYWORDS="~x86 -ppc -sparc "
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ [ `use crypt` ] || rm 8*
+
+ kernel_src_unpack
+}