summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-04-24 14:22:50 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-04-24 14:22:50 +0000
commit9c72bd75c89478b7e39f1d1d6152ce4331b886fe (patch)
treedf80719ea4cd13947f70b19efd75639799d93daa /sys-kernel
parentcleanup (diff)
downloadhistorical-9c72bd75c89478b7e39f1d1d6152ce4331b886fe.tar.gz
historical-9c72bd75c89478b7e39f1d1d6152ce4331b886fe.tar.bz2
historical-9c72bd75c89478b7e39f1d1d6152ce4331b886fe.zip
Backport #86968 fix to 2.6.8.1 headers.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-headers/ChangeLog6
-rw-r--r--sys-kernel/linux-headers/Manifest4
-rw-r--r--sys-kernel/linux-headers/files/linux-headers-2.6.8.1-appCompat.patch27
3 files changed, 33 insertions, 4 deletions
diff --git a/sys-kernel/linux-headers/ChangeLog b/sys-kernel/linux-headers/ChangeLog
index 279fa041a477..0f15f575f702 100644
--- a/sys-kernel/linux-headers/ChangeLog
+++ b/sys-kernel/linux-headers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/linux-headers
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.117 2005/04/21 18:36:17 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.118 2005/04/24 14:22:50 plasmaroo Exp $
+
+ 24 Apr 2005; <plasmaroo@gentoo.org>
+ files/linux-headers-2.6.8.1-appCompat.patch:
+ Backport #86968 fix to 2.6.8.1 headers.
21 Apr 2005; <plasmaroo@gentoo.org>
files/linux-headers-2.6.11-appCompat.patch:
diff --git a/sys-kernel/linux-headers/Manifest b/sys-kernel/linux-headers/Manifest
index 8dabbc89be0b..b2569d8b3c84 100644
--- a/sys-kernel/linux-headers/Manifest
+++ b/sys-kernel/linux-headers/Manifest
@@ -1,4 +1,4 @@
-MD5 8f6bd9c6589f405f2e938dc5da135847 ChangeLog 25159
+MD5 01897ea7810f0999d48b11934df5e30b ChangeLog 25287
MD5 b3099588e509bea5bf8c12f2b3882f58 linux-headers-2.2.26.ebuild 2509
MD5 c2c4eec01b604c30d0826e73ac02cac4 linux-headers-2.4.23.ebuild 3482
MD5 e9a0370039c1d4fe1b0f7c0be1eef478 linux-headers-2.6.11.ebuild 1522
@@ -24,7 +24,7 @@ MD5 45ff5cde07cfe93ecbb514226def606f files/generate-asm-sparc 1661
MD5 556c7008fbfdf81750bbd4ab2beb111e files/digest-linux-headers-2.2.26 67
MD5 6ef3887ee4018c06c18e8726767189c7 files/digest-linux-headers-2.4.22 67
MD5 33d51532d0f696fefa15593b2cf2f6de files/digest-linux-headers-2.0.40 66
-MD5 bcc6c6ebdba1fe999e710f26c6f403ce files/linux-headers-2.6.8.1-appCompat.patch 60685
+MD5 375b547b51c2fe7c30c2e08f6af82e8e files/linux-headers-2.6.8.1-appCompat.patch 61239
MD5 2574d3f1b776f2df365737f456bfe435 files/digest-linux-headers-2.4.26 67
MD5 57e8b81485f8a1ba10d41dd7949d40a8 files/linux-headers-2.6.8.1-strict-ansi-fix.patch 4132
MD5 602f7309c0163c018627f06b5f1ace3a files/linux-headers-2.6.8.1-arm-float.patch 640
diff --git a/sys-kernel/linux-headers/files/linux-headers-2.6.8.1-appCompat.patch b/sys-kernel/linux-headers/files/linux-headers-2.6.8.1-appCompat.patch
index ad9e140645a7..dd35bd7909e3 100644
--- a/sys-kernel/linux-headers/files/linux-headers-2.6.8.1-appCompat.patch
+++ b/sys-kernel/linux-headers/files/linux-headers-2.6.8.1-appCompat.patch
@@ -1332,10 +1332,19 @@ diff -up linux-2.6.8.1/include/linux/list.h linux-2.6.8.1-gentoo/include/linux/l
#include <linux/stddef.h>
#include <linux/prefetch.h>
#include <asm/system.h>
-@@ -38,20 +36,22 @@ struct list_head {
+@@ -38,20 +36,31 @@ struct list_head {
(ptr)->next = (ptr); (ptr)->prev = (ptr); \
} while (0)
++/**
++ * list_empty - tests whether a list is empty
++ * @head: the list to test.
++ */
++static inline int list_empty(const struct list_head *head)
++{
++ return head->next == head;
++}
++
+#if defined(__KERNEL__) || defined(__LINUX_KEYBOARD_H)
+
/*
@@ -1449,6 +1458,22 @@ diff -up linux-2.6.8.1/include/linux/list.h linux-2.6.8.1-gentoo/include/linux/l
}
/**
+@@ -244,15 +244,6 @@
+ }
+
+ /**
+- * list_empty - tests whether a list is empty
+- * @head: the list to test.
+- */
+-static inline int list_empty(const struct list_head *head)
+-{
+- return head->next == head;
+-}
+-
+-/**
+ * list_empty_careful - tests whether a list is
+ * empty _and_ checks that no other CPU might be
+ * in the process of still modifying either member
@@ -506,8 +506,8 @@ static inline int hlist_empty(const stru
static inline void __hlist_del(struct hlist_node *n)