summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2002-05-03 13:31:45 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2002-05-03 13:31:45 +0000
commitb89e1d9cd87498b85f27dcc2e479c1fbd00c3295 (patch)
tree004eb4a67a3a9aa299111533ea0dc39910d5c201 /sys-libs/cracklib
parentmasked new cracklib: testing (diff)
downloadhistorical-b89e1d9cd87498b85f27dcc2e479c1fbd00c3295.tar.gz
historical-b89e1d9cd87498b85f27dcc2e479c1fbd00c3295.tar.bz2
historical-b89e1d9cd87498b85f27dcc2e479c1fbd00c3295.zip
new cracklib (multi-arch): testing
Diffstat (limited to 'sys-libs/cracklib')
-rw-r--r--sys-libs/cracklib/cracklib-2.7-r5.ebuild33
-rw-r--r--sys-libs/cracklib/files/cracklib-2.7-gentoo-new.diff131
-rw-r--r--sys-libs/cracklib/files/digest-cracklib-2.7-r51
3 files changed, 165 insertions, 0 deletions
diff --git a/sys-libs/cracklib/cracklib-2.7-r5.ebuild b/sys-libs/cracklib/cracklib-2.7-r5.ebuild
new file mode 100644
index 000000000000..3e2efbf53250
--- /dev/null
+++ b/sys-libs/cracklib/cracklib-2.7-r5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.7-r3.ebuild,v 1.1 2002/03/17 22:55:24 azarah Exp
+
+S=${WORKDIR}/cracklib,${PV}
+DESCRIPTION="Cracklib"
+SRC_URI="ftp://ftp.debian.org/debian/dists/potato/main/source/utils/cracklib2_${PV}.orig.tar.gz"
+DEPEND="virtual/glibc sys-apps/miscfiles"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 <${FILESDIR}/${P}-redhat.patch || die
+ patch -p1 <${FILESDIR}/${P}-gentoo-new.diff || die
+}
+
+src_compile() {
+ # Parallel make does not work for 2.7
+ make all || die
+}
+
+src_install() {
+
+ dodir /usr/{lib,sbin,include} /usr/share/cracklib
+
+ make DESTDIR=${D} install || die
+
+ preplib /usr/lib
+
+ dodoc HISTORY LICENCE MANIFEST POSTER README
+}
diff --git a/sys-libs/cracklib/files/cracklib-2.7-gentoo-new.diff b/sys-libs/cracklib/files/cracklib-2.7-gentoo-new.diff
new file mode 100644
index 000000000000..faff0ce990e3
--- /dev/null
+++ b/sys-libs/cracklib/files/cracklib-2.7-gentoo-new.diff
@@ -0,0 +1,131 @@
+diff -N -r -U3 cracklib,2.7.orig/Makefile cracklib,2.7/Makefile
+--- cracklib,2.7.orig/Makefile Wed Dec 31 11:33:53 1997
++++ cracklib,2.7/Makefile Tue Feb 27 16:03:32 2001
+@@ -7,14 +7,21 @@
+ ###
+
+ ###
++# cracklib version
++MAJOR=2
++MINOR=7
++VERSION=$(MAJOR).$(MINOR)
++export MAJOR MINOR VERSION
++
++###
+ # set this to the absolute path (less extn) of compressed dict.
+
+-DICTPATH="/usr/local/lib/pw_dict"
++DICTPATH="/usr/lib/cracklib_dict"
+
+ ###
+ # Set this to the path of one or more files continaing wordlists.
+
+-SRCDICTS=/usr/dict/words
++SRCDICTS=/usr/share/dict/words /usr/share/dict/extra.words
+
+ ###
+ # If you have installed the cracklib-dicts directory, use this
+@@ -36,7 +43,9 @@
+ -rm -f all installed Part* *.BAK *.bak *~
+
+ install: all
++ ( cd cracklib && make install && exit $$? )
++ ( cd util && make install && exit $$? )
+ @echo 'if "sort" dies from lack of space, see "util/mkdict"'
+- util/mkdict $(SRCDICTS) | util/packer $(DICTPATH)
++ util/mkdict $(SRCDICTS) | LD_LIBRARY_PATH=cracklib util/packer $(DESTDIR)$(DICTPATH)
+ touch installed
+ ### @echo 'now go install passwd/passwd where you want it'
+diff -N -r -U3 cracklib,2.7.orig/cracklib/Makefile cracklib,2.7/cracklib/Makefile
+--- cracklib,2.7.orig/cracklib/Makefile Sun Dec 14 23:49:21 1997
++++ cracklib,2.7/cracklib/Makefile Tue Feb 27 16:03:39 2001
+@@ -6,13 +6,21 @@
+ # and upwards.
+ ###
+
+-LIB= libcrack.a
+-OBJ= fascist.o packlib.o rules.o stringlib.o
+-CFLAGS= -O -I../cracklib -DIN_CRACKLIB
++LIB = libcrack.so
++OBJ = fascist.o packlib.o rules.o stringlib.o
++CFLAGS += -g -I../cracklib -DIN_CRACKLIB -fPIC
++LD = ld
+
+-$(LIB): $(OBJ)
+- ar rv $(LIB) $?
+- -ranlib $(LIB)
++$(LIB): $(OBJ) Makefile
++ $(LD) -shared -soname $(LIB).$(MAJOR) -o $(LIB).$(VERSION) $(OBJ) -lc
++ rm -f $(LIB).$(MAJOR) $(LIB)
++ ln -s $(LIB).$(VERSION) $(LIB).$(MAJOR)
++ ln -s $(LIB).$(MAJOR) $(LIB)
+
+ clean:
+- -rm -f $(OBJ) $(LIB) *~
++ -rm -f $(OBJ) $(LIB) $(LIB).$(VERSION) *~
++
++install: $(LIB) crack.h
++ install -m 755 $(LIB).$(VERSION) $(DESTDIR)/usr/lib
++ ln -sf $(LIB).$(VERSION) $(DESTDIR)/usr/lib/$(LIB)
++ install -m 644 crack.h $(DESTDIR)/usr/include
+diff -N -r -U3 cracklib,2.7.orig/util/Makefile cracklib,2.7/util/Makefile
+--- cracklib,2.7.orig/util/Makefile Sun Dec 14 23:49:34 1997
++++ cracklib,2.7/util/Makefile Tue Feb 27 16:03:46 2001
+@@ -14,27 +14,31 @@
+ #SunOS users (and others?) should consider static linking of their passwd binary
+ #CFLAGS= -O -I../cracklib '-DCRACKLIB_DICTPATH="$(DICTPATH)"' -Bstatic
+
+-CFLAGS= -O -I../cracklib '-DCRACKLIB_DICTPATH="$(DICTPATH)"'
+-LIBS= ../cracklib/libcrack.a
++CFLAGS += -I../cracklib '-DCRACKLIB_DICTPATH="$(DICTPATH)"'
++LDFLAGS = -L../cracklib -lcrack
++LIBS = ../cracklib/libcrack.so
+
+ all: packer unpacker testnum teststr testlib
+ touch all
+
+ packer: packer.o $(LIBS)
+- cc $(CFLAGS) -o $@ $@.o $(LIBS)
++ cc $(CFLAGS) -o $@ $@.o $(LDFLAGS)
+
+ unpacker: unpacker.o $(LIBS)
+- cc $(CFLAGS) -o $@ $@.o $(LIBS)
++ cc $(CFLAGS) -o $@ $@.o $(LDFLAGS)
+
+ testnum: testnum.o $(LIBS)
+- cc $(CFLAGS) -o $@ $@.o $(LIBS)
++ cc $(CFLAGS) -o $@ $@.o $(LDFLAGS)
+
+ teststr: teststr.o $(LIBS)
+- cc $(CFLAGS) -o $@ $@.o $(LIBS)
++ cc $(CFLAGS) -o $@ $@.o $(LDFLAGS)
+
+ testlib: testlib.o $(LIBS)
+- cc $(CFLAGS) -o $@ $@.o $(LIBS)
++ cc $(CFLAGS) -o $@ $@.o $(LDFLAGS)
+
+ clean:
+ -rm *.o *~ all
+ -rm teststr testnum testlib packer unpacker
++
++install: all create-cracklib-dict
++ install -m 755 mkdict packer create-cracklib-dict $(DESTDIR)/usr/sbin
+diff -N -r -U3 cracklib,2.7.orig/util/create-cracklib-dict cracklib,2.7/util/create-cracklib-dict
+--- cracklib,2.7.orig/util/create-cracklib-dict Thu Jan 1 01:00:00 1970
++++ cracklib,2.7/util/create-cracklib-dict Tue Feb 27 16:03:51 2001
+@@ -0,0 +1,15 @@
++#!/bin/sh
++if [ -z "$*" ]; then
++ echo "Usage:"
++ echo " /usr/sbin/create-cracklib-dict wordlist ..."
++ echo
++ echo "This script takes one or more word list files as arguments"
++ echo "and converts them into cracklib dictionaries for use"
++ echo "by password checking programs. The results are placed in"
++ echo "/usr/lib/cracklib_dict.*"
++ echo
++ echo "Example:"
++ echo "/usr/sbin/create-cracklib-dict /usr/dict/words"
++else
++ /usr/sbin/mkdict $* | /usr/sbin/packer /usr/share/cracklib/pw_dict
++fi
diff --git a/sys-libs/cracklib/files/digest-cracklib-2.7-r5 b/sys-libs/cracklib/files/digest-cracklib-2.7-r5
new file mode 100644
index 000000000000..a7b3902bc30f
--- /dev/null
+++ b/sys-libs/cracklib/files/digest-cracklib-2.7-r5
@@ -0,0 +1 @@
+MD5 7f810e310c7f2df33d1eaa2b41ab2435 cracklib2_2.7.orig.tar.gz 20901