summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-07 16:10:52 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-07 16:10:52 +0000
commit164c7e7c7847905111f9af162f8dfa42de0a6a37 (patch)
tree7f90ac00def8e3767b1cc8fdd367bfe0d57d84bd /sys-libs/gdbm
parentMaintainence and FHS 2.1 fixes for RC4 (diff)
downloadhistorical-164c7e7c7847905111f9af162f8dfa42de0a6a37.tar.gz
historical-164c7e7c7847905111f9af162f8dfa42de0a6a37.tar.bz2
historical-164c7e7c7847905111f9af162f8dfa42de0a6a37.zip
Maintainence and FHS 2.1 fixes for RC4
Diffstat (limited to 'sys-libs/gdbm')
-rw-r--r--sys-libs/gdbm/gdbm-1.8.0-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-libs/gdbm/gdbm-1.8.0-r2.ebuild b/sys-libs/gdbm/gdbm-1.8.0-r2.ebuild
new file mode 100644
index 000000000000..4ca4efca5620
--- /dev/null
+++ b/sys-libs/gdbm/gdbm-1.8.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.0-r2.ebuild,v 1.1 2001/02/07 16:10:52 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU database libraries included for compatibility with Perl"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gdbm/${A}
+ ftp://prep.ai.mit.edu/gnu/gdbm/${A}"
+
+HOMEPAGE="http://www.gnu.org/software/gdbm/gdbm.html"
+
+DEPEND="virtual/glibc
+ berkdb? ( =sys-libs/db-1.85-r1 )"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info
+ try make CFLAGS=\"${CFLAGS} -fomit-frame-pointer\" ${MAKEOPTS}
+}
+
+src_install() {
+
+ try make prefix=${D}/usr install
+ dodoc COPYING ChangeLog NEWS README
+
+}
+
+
+